Notice:
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

"GATK_STACKTRACE_ON_USER_EXCEPTION" Error in GATK4.0.5.1

dkdasdkdas MumbaiMember

Dear Sir,
I am a new user of NGS analysis. I am working on whole exome analysis sequenced with Illumina using Agilent exon capture kit. I follow GATK best practices for analysis in CentOS operating system. Following are the sequential steps for NGS analysis
1. Allignment with bwa mem
2. sorting the reads by SortSam of Picard tool
3. Markduplicates and remove duplicate by Picard tool
4. RealignerTargetCreator of GATK for knownindels.intervals
5. IndelRealigner of GATK for indelrealigned.bam
6. BaseRecalibrator of GATK for recal_data.table
7. BaseRecalibrator of GATK for post_recal_data.table
8. PrintReads of GATK for post_recall_bam
9. HaplotypeCaller of GATK for raw.snps.indels.g.vcf
10. GenotypeGVCFs of GATK for raw_variants.vcf.
11. Then i ran the following command for tranches file

$gatk VariantRecalibrator -R /home/dkdas/Softwares-NGS/ucsc.hg19.fasta -input 5_FSCZ035.raw_variants.vcf -resource:hapmap,known=false,training=true,truth=true,prior=15.0 /home/dkdas/Softwares-NGS/hapmap_3.3.hg19.sites.vcf -resource:omni,known=false,training=true,truth=true,prior=12.0 /home/dkdas/Softwares-NGS/1000G_omni2.5.hg19.sites.vcf -resource:1000G,known=false,training=true,truth=false,prior=10.0 /home/dkdas/Softwares-NGS/1000G_phase1.snps.high_confidence.hg19.sites.vcf -resource:dbsnp,known=true,training=false,truth=false,prior=2.0 /home/dkdas/Softwares-NGS/dbsnp_138.hg19.vcf -an DP -an QD -an FS -an MQRankSum -an ReadPosRankSum -mode SNP -tranche 100.0 -tranche 99.9 -tranche 99.0 -tranche 90.0 -recalFile 5_FSCZ035.recalibrate_SNP.recal -tranchesFile 5_FSCZ035.recalibrate_SNP.tranches -nt 8 -rscriptFile 5_FSCZ035.recalibrate_SNP_plots.R

However, when i ran this command, a stack trace error message was thrown as "Set the system property GATK_STACKTRACE_ON_USER_EXCEPTION (--java-options '-DGATK_STACKTRACE_ON_USER_EXCEPTION=true') to print the stack trace."
Please let me know what java arguments I need to add in the command line to successfully run the VariantRecalibrator. To overcome this error I used the earlier version of GATK i.e. "GenomeAnalysisTK-3.8-0-ge9d806836/GenomeAnalysisTK.jar", however, it gave me same type of error "ERROR stack trace".
Please guide me how to overcome this problem.
Thank you in anticipation
Dhanjit

Best Answer

Answers

  • dkdasdkdas MumbaiMember

    Hi Sheila,
    Thank you so much for your help. I could run gatk with --java-options, however, running the command again an user error has occured "recal-file is not a recognized option". Am I using the correct version of GATK (gatk4.0.5.1)? I am following the arguments given in gatk-doc "/gatk-4.0.5.1/gatkdoc/org_broadinstitute_hellbender_tools_walkers_vqsr_VariantRecalibrator.html"

    The entire command is pasted below

    $ gatk --java-options '-DGATK_STACKTRACE_ON_USER_EXCEPTION=true' VariantRecalibrator -R /home/dkdas/Softwares-NGS/ucsc.hg19.fasta -input N076_start.raw_variants.vcf --resource hapmap,known=false,training=true,truth=true,prior=15.0:/home/dkdas/Softwares-NGS/hapmap_3.3.hg19.sites.vcf --resource omni,known=false,training=true,truth=true,prior=12.0:/home/dkdas/Softwares-NGS/1000G_omni2.5.hg19.sites.vcf --resource 1000G,known=false,training=true,truth=false,prior=10.0:/home/dkdas/Softwares-NGS/1000G_phase1.snps.high_confidence.hg19.sites.vcf --resource dbsnp,known=true,training=false,truth=false,prior=2.0:/home/dkdas/Softwares-NGS/dbsnp_138.hg19.vcf -an DP -an QD -an FS -an MQRankSum -an ReadPosRankSum -mode SNP -tranche 100.0 -tranche 99.9 -tranche 99.0 -tranche 90.0 --recal-file 6_FSCZ035.recalibrate_SNP.recal --tranches-file 6_FSCZ035.recalibrate_SNP.tranches --rscript-file 5_FSCZ035.recalibrate_SNP_plots.R

    Kindly suggest how to create the "recal-file" using VariantRecalibrator

    Best regards,

    Dhanjit

  • SheilaSheila Broad InstituteMember, Broadie, Moderator admin

    @dkdas
    Hi Dhanjit,

    Hmm. Can you try -recal-file instead of --recal-file?

    -Sheila

Sign In or Register to comment.