Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

log10LikelihoodsOfAC are bad in GenotypeGVCFs 4.0.5.x when using -new-qual flag

Dear,

I am trying to do joint genotyping on a large cohort of samples (~1000 WES samples)

First, I followed GATK best practices 4.0.4 as it was the latest version at that moment.
I encountered memory issues as reported earlier.
A solution to this was to use 4.0.5.x and add the '-new-qual' tag.

However, when doing so I encounter another error:
java.lang.IllegalArgumentException: log10LikelihoodsOfAC are bad 4.579892256552976E-21,NaN

I encounter this for all my regions.

So to summarize: I first do GenomicsDBImport with default options which returns true.
Next, GenotypeGVCFs starts, but after some milions of bases I encouter log10LikelihoodsOfAC error.

What could be the cause of this?

Best wishes,
Wouter

Answers

  • WSTWST Member

    In GATK 4.0.4 the analysis worked well with the '-new-qual' tag.
    Is there a reason why it doesn't work in GATK 4.0.5?
    I have to add that the variants were called with GATK haplotypecaller 3.8

    best wishes

  • SheilaSheila Broad InstituteMember, Broadie, Moderator admin

    @WST
    Hi Wouter,

    Glad to hear using 4.0.4.0 worked.

    It looks like 4.0.5.0 added some new code related to newQual, so that could have caused the crash. It is best to stick to the same version.

    -Sheila

Sign In or Register to comment.