Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

funcotator error

zwzhangzwzhang Member, Broadie

Hi, FireCloud team

Sorry for the duplicated question. I just want to update the format.

I ran into a problem recently coming from Funcotator. I initially run Mutect2 coupled with Funcotator on FireCloud, GATK 4.0.4.0 version, but it throw out some error. And I also tried run Funcotator locally and it produces the almost identical error, see below

[June 6, 2018 1:47:32 PM EDT] org.broadinstitute.hellbender.tools.funcotator.Funcotator done. Elapsed time: 12.63 minutes.
Runtime.totalMemory()=12082741248
java.lang.StringIndexOutOfBoundsException: String index out of range: -61
    at java.lang.String.substring(String.java:1967)
    at org.broadinstitute.hellbender.tools.funcotator.dataSources.gencode.GencodeFuncotationFactory.createUtrFuncotation(GencodeFuncotationFactory.java:1088)
    at org.broadinstitute.hellbender.tools.funcotator.dataSources.gencode.GencodeFuncotationFactory.createGencodeFuncotationOnTranscript(GencodeFuncotationFactory.java:601)
    at org.broadinstitute.hellbender.tools.funcotator.dataSources.gencode.GencodeFuncotationFactory.createFuncotationsHelper(GencodeFuncotationFactory.java:529)
    at org.broadinstitute.hellbender.tools.funcotator.dataSources.gencode.GencodeFuncotationFactory.createFuncotationsOnVariant(GencodeFuncotationFactory.java:276

I know Funcotator is still in beta version, but want to ask you help me debug this problem and I am also wondering is there any more stable Funcotator.

Thanks,
Zhouwei

Comments

  • KateNKateN Cambridge, MAMember, Broadie, Moderator admin

    Thank you for updating your format-- It certainly helps to see error messages in code brackets.

    Unfortunately, I'm unable to help you with your error, but I think one of my colleagues @Sheila or @shlee may be able to. I'm moving your question to the GATK forum where they will be able to assist with Funcotator.

  • shleeshlee CambridgeMember, Broadie ✭✭✭✭✭

    Hi @zwzhang,

    The developer says that updating to GATK4.0.5.0 should solve the issue. Also, please be sure to use the latest data sources.

Sign In or Register to comment.