CNNScoreVariants no suitable codecs found erro

When first testing the CNNScoreVariants, the following error occurs. I have tried this on several bam/cram files that result in the same error. These cram have run fine with other GATK tools. As a pre-req, I did run pip install vqsr_cnn.

Any workarounds for this?

Using GATK jar /share/pkg/gatk/4.0.3.0/install/bin/gatk-package-4.0.3.0-local.jar
Running:
    java -Dsamjdk.use_async_io_read_samtools=false -Dsamjdk.use_async_io_write_samtools=true -Dsamjdk.use_async_io_write_tribble=false -Dsamjdk.compression_level=2 -DGATK_STACKTRACE_ON_USER_EXCEPTION=true -jar /share/pkg/gatk/4.0.3.0/install/bin/gatk-package-4.0.3.0-local.jar CNNScoreVariants -V /restricted/projectnb/casa/wgs.hg38/adni/cram/ADNI_016_s_4584.hg38.realign.bqsr.cram -R /restricted/projectnb/casa/ref/GRCh38_full_analysis_set_plus_decoy_hla.fa -O cnn./restricted/projectnb/casa/wgs.hg38/adni/cram/ADNI_016_s_4584.hg38.realign.bqsr.cram
07:24:39.726 INFO  NativeLibraryLoader - Loading libgkl_compression.so from jar:file:/share/pkg/gatk/4.0.3.0/install/bin/gatk-package-4.0.3.0-local.jar!/com/intel/gkl/native/libgkl_compression.so
07:24:39.869 INFO  CNNScoreVariants - ------------------------------------------------------------
07:24:39.869 INFO  CNNScoreVariants - The Genome Analysis Toolkit (GATK) v4.0.3.0
07:24:39.870 INFO  CNNScoreVariants - For support and documentation go to https://software.broadinstitute.org/gatk/
07:24:39.870 INFO  CNNScoreVariants - Executing as [email protected] on Linux v2.6.32-696.28.1.el6.x86_64 amd64
07:24:39.870 INFO  CNNScoreVariants - Java runtime: Java HotSpot(TM) 64-Bit Server VM v1.8.0_151-b12
07:24:39.870 INFO  CNNScoreVariants - Start Date/Time: May 30, 2018 7:24:39 AM EDT
07:24:39.870 INFO  CNNScoreVariants - ------------------------------------------------------------
07:24:39.870 INFO  CNNScoreVariants - ------------------------------------------------------------
07:24:39.871 INFO  CNNScoreVariants - HTSJDK Version: 2.14.3
07:24:39.871 INFO  CNNScoreVariants - Picard Version: 2.17.2
07:24:39.871 INFO  CNNScoreVariants - HTSJDK Defaults.COMPRESSION_LEVEL : 2
07:24:39.871 INFO  CNNScoreVariants - HTSJDK Defaults.USE_ASYNC_IO_READ_FOR_SAMTOOLS : false
07:24:39.871 INFO  CNNScoreVariants - HTSJDK Defaults.USE_ASYNC_IO_WRITE_FOR_SAMTOOLS : true
07:24:39.871 INFO  CNNScoreVariants - HTSJDK Defaults.USE_ASYNC_IO_WRITE_FOR_TRIBBLE : false
07:24:39.872 INFO  CNNScoreVariants - Deflater: IntelDeflater
07:24:39.872 INFO  CNNScoreVariants - Inflater: IntelInflater
07:24:39.872 INFO  CNNScoreVariants - GCS max retries/reopens: 20
07:24:39.872 INFO  CNNScoreVariants - Using google-cloud-java patch 6d11bef1c81f885c26b2b56c8616b7a705171e4f from https://github.com/droazen/google-cloud-java/tree/dr_all_nio_fixes
07:24:39.872 WARN  CNNScoreVariants -

   !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

   Warning: CNNScoreVariants is an EXPERIMENTAL tool and should not be used for production

   !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!


07:24:39.872 INFO  CNNScoreVariants - Initializing engine
07:24:40.566 INFO  CNNScoreVariants - Shutting down engine
[May 30, 2018 7:24:40 AM EDT] org.broadinstitute.hellbender.tools.walkers.vqsr.CNNScoreVariants done. Elapsed time: 0.01 minutes.
Runtime.totalMemory()=1829240832
***********************************************************************

A USER ERROR has occurred: Cannot read /restricted/projectnb/casa/wgs.hg38/adni/cram/ADNI_016_s_4584.hg38.realign.bqsr.cram because no suitable codecs found

***********************************************************************
org.broadinstitute.hellbender.exceptions.UserException$NoSuitableCodecs: Cannot read /restricted/projectnb/casa/wgs.hg38/adni/cram/ADNI_016_s_4584.hg38.realign.bqsr.cram because no suitable codecs found
        at org.broadinstitute.hellbender.engine.FeatureManager.getCodecForFile(FeatureManager.java:436)
        at org.broadinstitute.hellbender.engine.FeatureDataSource.getCodecForFeatureInput(FeatureDataSource.java:327)
        at org.broadinstitute.hellbender.engine.FeatureDataSource.getFeatureReader(FeatureDataSource.java:307)
        at org.broadinstitute.hellbender.engine.FeatureDataSource.<init>(FeatureDataSource.java:255)
        at org.broadinstitute.hellbender.engine.VariantWalker.initializeDrivingVariants(VariantWalker.java:55)
        at org.broadinstitute.hellbender.engine.VariantWalkerBase.initializeFeatures(VariantWalkerBase.java:47)
        at org.broadinstitute.hellbender.engine.GATKTool.onStartup(GATKTool.java:558)
        at org.broadinstitute.hellbender.engine.VariantWalker.onStartup(VariantWalker.java:43)
        at org.broadinstitute.hellbender.cmdline.CommandLineProgram.runTool(CommandLineProgram.java:132)
        at org.broadinstitute.hellbender.cmdline.CommandLineProgram.instanceMainPostParseArgs(CommandLineProgram.java:179)
        at org.broadinstitute.hellbender.cmdline.CommandLineProgram.instanceMain(CommandLineProgram.java:198)
        at org.broadinstitute.hellbender.Main.runCommandLineProgram(Main.java:160)
        at org.broadinstitute.hellbender.Main.mainEntry(Main.java:203)
        at org.broadinstitute.hellbender.Main.main(Main.java:289)

Answers

Sign In or Register to comment.