GATK vesrion supporting reduce reads.

ManishManish IndiaMember
edited May 2018 in Ask the GATK team

I am working on one old pipeline using GATK but that pipleline uses reducereads as parameter. I found GATK version < 3.0 support reduce-reads so i tried following versions (downloaded from https://software.broadinstitute.org/gatk/download/archive )

GenomeAnalysisTK-2.8-1-g932cd3a.tar.gz
GenomeAnalysisTK-2.7-4-g6f46d11.tar.gz
GenomeAnalysisTK-2.6-5-gba531bd.tar.gz
GenomeAnalysisTK-2.5-2-gf57256b.tar.gz
GenomeAnalysisTK-2.1-9-gb90951c.tar.gz
GenomeAnalysisTK-2.2-9-g54ae978.tar.gz
GenomeAnalysisTK-2.4-9-g532efad.tar.gz

But even when i run
java -jar GenomeAnalysisTK.jar --version
or
java -jar GenomeAnalysisTK.jar --help

i get following error message

ERROR MESSAGE: Code exception (see stack trace for error itself)

May i know which version is supporting reduce read parameter?

Tagged:

Answers

  • SheilaSheila Broad InstituteMember, Broadie, Moderator admin

    @Manish
    Hi,

    Can you post the full stack trace?

    Thanks,
    Sheila

  • ManishManish IndiaMember

    Please find below full stack trace.

    [email protected]:/illumina/genomekey-data/tools/GenomeAnalysisTK-2.8# java -jar GenomeAnalysisTK.jar --help

    ERROR ------------------------------------------------------------------------------------------
    ERROR stack trace

    java.lang.ExceptionInInitializerError
    at org.broadinstitute.sting.gatk.GenomeAnalysisEngine.(GenomeAnalysisEngine.java:167)
    at org.broadinstitute.sting.gatk.CommandLineExecutable.(CommandLineExecutable.java:53)
    at org.broadinstitute.sting.gatk.CommandLineGATK.(CommandLineGATK.java:54)
    at org.broadinstitute.sting.gatk.CommandLineGATK.main(CommandLineGATK.java:90)
    Caused by: java.lang.NullPointerException
    at org.reflections.Reflections.scan(Reflections.java:220)
    at org.reflections.Reflections.scan(Reflections.java:166)
    at org.reflections.Reflections.(Reflections.java:94)
    at org.broadinstitute.sting.utils.classloader.PluginManager.(PluginManager.java:79)
    ... 4 more

    ERROR ------------------------------------------------------------------------------------------
    ERROR A GATK RUNTIME ERROR has occurred (version 2.8-1-g932cd3a):
    ERROR
    ERROR This might be a bug. Please check the documentation guide to see if this is a known problem.
    ERROR If not, please post the error message, with stack trace, to the GATK forum.
    ERROR Visit our website and forum for extensive documentation and answers to
    ERROR commonly asked questions http://www.broadinstitute.org/gatk
    ERROR
    ERROR MESSAGE: Code exception (see stack trace for error itself)
    ERROR ------------------------------------------------------------------------------------------
  • SheilaSheila Broad InstituteMember, Broadie, Moderator admin

    @Manish
    Hi,

    Which version of Java are you using? Have a look at this thread.

    -Sheila

Sign In or Register to comment.