Notice:
If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

VariantRecalibrator error

I am trying to run the Germline short variant discovery using GATK4 and following the steps found on: https://software.broadinstitute.org/gatk/best-practices/workflow?id=11145
everything runs ok until i reach the end where i\m supposed to run the VariantRecalibrator
the command is something like:

java -Xmx10g -jar /home/Downloads/gatk-4.0.3.0/gatk-package-4.0.3.0-local.jar \VariantRecalibrator --max-gaussians 4 \-R hg38.fa \-V myOutput.g.vcf \--resource known=false,training=true,truth=true,prior=15.0:hapmap_3.3.hg38.vcf.gz \--resource known=false,training=true,truth=false,prior=10.0:1000G_phase1.snps.high_confidence.hg38.vcf.gz \--resource known=false,training=true,truth=false,prior=12.0:1000G_omni2.5.hg38.vcf.gz \--resource known=true,training=true,truth=false,prior=2.0:Homo_sapiens_assembly38.dbsnp138.vcf.gz \-an GT \-mode SNP \-O output.recal \--tranches-file output.tranches \--rscript-file output.plots.R

where myOutput.g.vcf is the outout file from running HaplotypeCaller in gvcf mode

and i am getting the following error

A USER ERROR has occurred: Bad input: Values for GT annotation not detected for ANY training variant in the input callset. VariantAnnotator may be used to add these annotations.

I tried running VariantAnnotator first but the same error keeps on showing

Answers

Sign In or Register to comment.