Test-drive the GATK tools and Best Practices pipelines on Terra


Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

SplitNCigarReads unrecognized options

Hi,

I've been following the "Calling Variants in RNASeq" workflow, using the most recent version of gatk (v4.0.2.1).

When I run the SplitNCigarReads command I get the following error:

$gatk SplitNCigarReads -R /data/fasta/ensembl-Mus_musculus.fa -I /clscratch/kerrgr1/rnaseqVar/AB1-A1-medium/2Pass/Aligned.dedupped.bam -O /clscratch/kerrgr1/AAB312_rnaseqVar/AB1-A1-medium/2Pass/Aligned.split.bam -RF ReassignOneMappingQuality -RMQF 255 -RMQT 60 -U ALLOW_N_CIGAR_READS
Using GATK jar /home/kerrgr1/gatk-4.0.2.1/gatk-package-4.0.2.1-local.jar
Running:
java -Dsamjdk.use_async_io_read_samtools=false -Dsamjdk.use_async_io_write_samtools=true -Dsamjdk.use_async_io_write_tribble=false -Dsamjdk.compression_level=1 -jar /home/kerrgr1/gatk-4.0.2.1/gatk-package-4.0.2.1-local.jar SplitNCigarReads -R /db/nibrgenome/NG00012.0/fasta/ensembl-Mus_musculus.fa -I /clscratch/kerrgr1/AAB312_rnaseqVar/AB1-A1-medium/2Pass/Aligned.dedupped.bam -O /clscratch/kerrgr1/AAB312_rnaseqVar/AB1-A1-medium/2Pass/Aligned.split.bam -RF ReassignOneMappingQuality -RMQF 255 -RMQT 60 -U ALLOW_N_CIGAR_READS
USAGE: SplitNCigarReads [arguments]
....


A USER ERROR has occurred: U is not a recognized option


I also noticed in the usage options printed to screen that "ReassignOneMappingQuality" isn't an option for parameter "RF"

--read-filter,-RF:String Read filters to be applied before analysis This argument may be specified 0 or more
times. Default value: null. Possible Values: {AlignmentAgreesWithHeaderReadFilter,
AllowAllReadsReadFilter, AmbiguousBaseReadFilter, CigarContainsNoNOperator,
FirstOfPairReadFilter, FragmentLengthReadFilter, GoodCigarReadFilter,
HasReadGroupReadFilter, LibraryReadFilter, MappedReadFilter,
MappingQualityAvailableReadFilter, MappingQualityNotZeroReadFilter,
MappingQualityReadFilter, MatchingBasesAndQualsReadFilter, MateDifferentStrandReadFilter,
MateOnSameContigOrNoMappedMateReadFilter, MetricsReadFilter,
NonZeroFragmentLengthReadFilter, NonZeroReferenceLengthAlignmentReadFilter,
NotDuplicateReadFilter, NotOpticalDuplicateReadFilter, NotSecondaryAlignmentReadFilter,
NotSupplementaryAlignmentReadFilter, OverclippedReadFilter, PairedReadFilter,
PassesVendorQualityCheckReadFilter, PlatformReadFilter, PlatformUnitReadFilter,
PrimaryLineReadFilter, ProperlyPairedReadFilter, ReadGroupBlackListReadFilter,
ReadGroupReadFilter, ReadLengthEqualsCigarLengthReadFilter, ReadLengthReadFilter,
ReadNameReadFilter, ReadStrandFilter, SampleReadFilter, SecondOfPairReadFilter,
SeqIsStoredReadFilter, ValidAlignmentEndReadFilter, ValidAlignmentStartReadFilter,
WellformedReadFilter}

I also noticed that the online documentation specifies "-o" for the output file, whereas in practice it requires "-O".

Am I doing something blatantly wrong that I can't see?

Thanks for any help,
gkerrs

Answers

  • SheilaSheila Broad InstituteMember, Broadie, Moderator admin

    @gkerrs
    Hi gkerrs,

    I think those first two options are not necessary in GATK4. Let me know if you get an error when running without them. You may also find the WDLs here helpful.

    -Sheila

    P.S. Thanks for pointing out the doc error. I will fix it now.

  • FPBarthelFPBarthel HoustonMember ✭✭

    Hi @Sheila ! I am also trying to follow this workflow. Do I understand correctly that (to prepare input RNAseq BAM file for variant calling) in GATK 4 one no longer needs to supply the parameters "-RF ReassignOneMappingQuality -RMQF 255 -RMQT 60 -U ALLOW_N_CIGAR_READS" to gatk SplitNCigarReads? Thus, I only need to supply reference (-R), input BAM (-I) and output BAM (-O)?

  • SheilaSheila Broad InstituteMember, Broadie, Moderator admin

    @FPBarthel
    Hi,

    It does seem that way from the documentation :smile: Please let us know if you have issues running with just the basic inputs.

    Thanks,
    Sheila

  • FPBarthelFPBarthel HoustonMember ✭✭

    Thank you @Sheila ! It does seem to work fine and thanks for confirming. I wanted to be sure we are not missing something here.

Sign In or Register to comment.