VariantRecalibration step issue

Hi all, i need some advice about VariantRecalibration as in if I am doing the right thing?

Downloaded 30 bams from 1000 genomes and realigned them to HG38. Then using HaplotypeCaller generated a gVCF for each BAM. Then used CombineGVCFs and made a single VCF named cohort.g.vcf

Took a sample BAM and aligned to HG38. Then used HaplotypeCaller like above and generated a gVCF.

Now I am trying to genotype both the gVCFs using

java -Xmx16g -jar algorithms/gatk3/gatk3.8.jar -T GenotypeGVCFs -R references/hg38gatkbundle/Homo_sapiens_assembly38.fasta --variant data/HG100/HG100.output.raw.snps.indels.g.vcf --variant references/hg38gatkbundle/exomerefs/vcf/cohort.g.vcf -o data/HG100/output.raw.combined.vcf

This is not working. When I ran ValidateVCF from GATK, for my sample VCF i got message about --reference_window_size adjustment as in make it larger than 108, 170 etc. Then reran haplotype caller with --set_window_size 1000 but there is no change, same validation message.

ValidateVariants on the cohort.g.vcf reports a broken line.

I am not just not sure why these issues arise.

Is there a simple straightforward pipeline/ tutorial published somewhere that helps get over this issue?

Any help will be highly appreciated.

Answers

  • SheilaSheila Broad InstituteMember, Broadie, Moderator

    @Ashwin
    Hi,

    You can use ValidateVariants with --validate-GVCF to validate your GVCFs.

    What error do you get when you run GenotypeGVCFs? Are you using the latest version of GATK?

    -Sheila

  • Here is one of the messages when running ValidateVariants with --validate-GVCF turned on.

    Reference allele is too long (111) at position chrX:66337692; skipping that record. Set --reference_window_stop >= 111

    I have already run HaplotypeCaller with --reference_window_stop 1000 but no luck?

    When I run GenotypeGVCFs I get line malformed error in one of the files so program stops. I am using GATK3.8

    Any ideas?

  • SheilaSheila Broad InstituteMember, Broadie, Moderator
    edited March 5

    @Ashwin
    Hi,

    Okay, so can you try running GenotypeGVCFs per-chromosome? Is chrX the only chromosome that throws the error? Is the error message from GenotypeGVCFs pointing to the same position from ValidateVariants?

    Thanks,
    Sheila

    P.S. Some other threads suggest this error arises from mismatching reference and VCF alleles. Can you post the exact command you ran for HaplotypeCaller? Can you also post the FASTA dict file and VCF header that shows the contigs?

Sign In or Register to comment.