BWA MEM is not working

Dear Folks
I started learning sequencing using GATK howto tutorial
https://software.broadinstitute.org/...le.php?id=8017

I ran command
bwa index chr19_chr19_KI270866v1_alt.fasta

and it generated 5 files (.pac, .bwt, .ann, .amb and .sa)

When I ran the second command
bwa mem chr19_chr19_KI270866v1_alt.fasta 8017_read1.fq 8017_read2.fq > 8017_bwamem.sam

The systems says “[main] unrecognized command 'mem'”

I have 2 questions
1. Why it says that 'mem' is not a command
2. I assume that we will use product of bwa index command in bwa mem command. But here again in tutorial we are using same fasta file as reference genome and aligning it with our query reads 1 and 2. Why?

Answers

  • SkyWarriorSkyWarrior TurkeyMember

    what is your BWA version ? How did you obtain bwa ? Are you using a mac?

    If you are using a very old BWA version then mem may not be available. also if you are using a mac and you are typing your commands a little too fast then you are caught by the undetected whitespace bug. If that's the case just close the terminal open a new one and try typing you command a little slower. Also using a text editor to type your commands ahead of time and copying and pasting them may solve your problem as well.

    If this is not the case then try obtaining the latest source version of BWA from the sourceforge pate 0.7.17 and recompile using the make command. Also make sure that the new compiled version is in the path not an old version already installed in /usr/bin.

    Fasta file is used to as a pointer and reference file for the alignment process. when bwa indexes a reference genome all the files generated by bwa are related to the fasta file so instead of using all files as seperate parameters you just indicate the place of the fasta file where other files should reside as well.

Sign In or Register to comment.