On Monday and Tuesday, November 12-13, the communications team will be out of the office for a U.S. federal holiday and a team event. We will be back in action on November 14th and apologize for any inconvenience this may cause. Thank you for using the forum.

VariantRecalibrator ERROR: Bad input: Found annotations with zero variance. They must be excluded be

Hello GATK Team,

Below is the the partial pipeline of my code and I have ** the VariantRecalibrator tool line where I am getting the error:
os.system('java -Xmx40g -Djava.io.tmpdir=/Users/seyfim/tmp -jar /Users/seyfim/software/GenomeAnalysisTK-3.7-0/GenomeAnalysisTK.jar -T HaplotypeCaller -R '+hg19+' -ERC GVCF --variant_index_type LINEAR --variant_index_parameter 128000 -I '+n+'.sample.bam --dbsnp '+dbsnp+' -stand_call_conf 20 -o '+n+'.g.vcf’)

os.system('java -Xmx6g -Djava.io.tmpdir=/Users/seyfim/tmp -jar /Users/seyfim/software/GenomeAnalysisTK-3.7-0/GenomeAnalysisTK.jar -T GenotypeGVCFs -ERC GVCF '+hg19+' --variant '+n+'.g.vcf -o ALL_SAMPLES.vcf’)

os.system('java -Xmx40g -Djava.io.tmpdir=/Users/seyfim/tmp -jar /Users/seyfim/software/GenomeAnalysisTK-3.7-0/GenomeAnalysisTK.jar -T VariantAnnotator -R '+hg19+' -I '+n+'.sample.bam -o '+n+'.sample.raw.vcf -A Coverage --variant ALL_SAMPLES.vcf -L ALL_SAMPLES.vcf --dbsnp /Users/seyfim/working/bwa_working/DbSNP137_hg19.vcf’)

os.system('java -Xmx28g -Djava.io.tmpdir=/Users/seyfim/tmp -jar /Users/seyfim/software/picard.jar UpdateVcfSequenceDictionary I= '+n+'.sample.raw.vcf O='+n+'.sorted.raw.vcf SEQUENCE_DICTIONARY='+reference_dictionary+'')

** os.system('java -Xmx40g -Djava.io.tmpdir=/Users/seyfim/tmp -jar /Users/seyfim/software/GenomeAnalysisTK-3.7-0/GenomeAnalysisTK.jar -T VariantRecalibrator -R '+hg19+' -input '+n+'.sorted.raw.vcf -resource:hapmap,known=false,training=true,truth=true,prior=15.0 '+hapmap+' -resource:omni,known=false,training=true,truth=false,prior=12.0 '+omni+' -resource:1000G,known=false,training=true,truth=false,prior=10.0 '+SNPs+' -resource:dbsnp,known=true,training=false,truth=false,prior=2.0 '+dbsnp+' -an QD -an MQ -an MQRankSum -an ReadPosRankSum -an FS -an ClippingRankSum -mode SNP -L ALL_SAMPLES.vcf -U ALLOW_SEQ_DICT_INCOMPATIBILITY -recalFile '+n+'.output.recal -tranchesFile '+n+'.output.tranches')

Here is the error I am getting:

ERROR ------------------------------------------------------------------------------------------
ERROR A USER ERROR has occurred (version 3.7-0-gcfedb67):
ERROR
ERROR This means that one or more arguments or inputs in your command are incorrect.
ERROR The error message below tells you what is the problem.
ERROR
ERROR If the problem is an invalid argument, please check the online documentation guide
ERROR (or rerun your command with --help) to view allowable command-line arguments for this tool.
ERROR
ERROR Visit our website and forum for extensive documentation and answers to
ERROR commonly asked questions https://software.broadinstitute.org/gatk
ERROR
ERROR Please do NOT post this error to the GATK forum unless you have really tried to fix it yourself.
ERROR
ERROR MESSAGE: Bad input: Found annotations with zero variance. They must be excluded before proceeding.
ERROR ------------------------------------------------------------------------------------------

I have checked the forum, made adjustments and still cannot get this tool to work, any help is greatly appreciated :)

Best Answer

Answers

  • Thanks Shelia!

    It turns out the -an ClippingRankSum that was throwing the errror. I ended up using the following command and it worked! I had to keep the -U ALLOW_SEQ

    os.system('java -Xmx40g -Djava.io.tmpdir=/Users/seyfim/tmp -jar /Users/seyfim/software/GenomeAnalysisTK-3.7-0/GenomeAnalysisTK.jar -T VariantRecalibrator -R '+hg19+' -input '+n+'.sorted.raw.vcf -resource:hapmap,known=false,training=true,truth=true,prior=15.0 '+hapmap+' -resource:omni,known=false,training=true,truth=false,prior=12.0 '+omni+' -resource:1000G,known=false,training=true,truth=false,prior=10.0 '+SNPs+' -resource:dbsnp,known=true,training=false,truth=false,prior=2.0 '+dbsnp+' -an QD -an MQRankSum -an ReadPosRankSum -an FS -an DP -an SOR -mode SNP -L ALL_SAMPLES.vcf -U ALLOW_SEQ_DICT_INCOMPATIBILITY -recalFile '+n+'.output.recal -tranchesFile '+n+'.output.tranches

Sign In or Register to comment.