If you happen to see a question you know the answer to, please do chime in and help your fellow community members. We encourage our fourm members to be more involved, jump in and help out your fellow researchers with their questions. GATK forum is a community forum and helping each other with using GATK tools and research is the cornerstone of our success as a genomics research community.We appreciate your help!

Test-drive the GATK tools and Best Practices pipelines on Terra

Check out this blog post to learn how you can get started with GATK and try out the pipelines in preconfigured workspaces (with a user-friendly interface!) without having to install anything.

Running GATK from docker repository on Cancer Genomic Cloud (CGC)


I'm having some problems running GATK on the Cancer Genomic Cloud (CGC) platform.
I've created my own tool using the following docker repository ''' broadinstitute/gatk:4.beta.5 '''
I'm using the following command line: ''' ./gatk-launch --javaOptions -d64 Mutect2 ''' etc. but the log file says ''' .2017-10-05T16:43:21.877696876Z sh: 1: ./gatk-launch: not found '''
I tried also using only ''' gatk-launch ''' with no results.
I thought there was an error in the repository path i wrote but it should be ok as, according to the log file, it seems it was opened correctly.

2017-10-05 16:42:02: Download completed.
2017-10-05 16:42:02: Docker pull started. Image: broadinstitute/gatk:latest
2017-10-05 16:43:20: Docker pull completed.
2017-10-05 16:43:21: Starting docker container.
2017-10-05 16:43:21: Docker container started.
2017-10-05 16:43:21: Executing command: ./gatk-launch --javaOptions -d64 Mutect2 etc. etc. '''

thank you very much.


  • SheilaSheila Broad InstituteMember, Broadie, Moderator admin
    edited October 2017


    Can you clarify what you mean by "I tried also using only ''' gatk-launch ''' with no results." Did you try downloading the latest gatk4 from here and running Mutect2 on your own computer?


    EDIT: If you did run Mutect2 on your own computer, can you post the error message/log output you get?

  • PuputnikPuputnik ItalyMember

    Hi Sheila,

    No, i didn't run Mutect2 on my computer, i meant i tried to use "gatk-launch" without "./"
    Anyway, i solved it, i was able to invoke it with "/*/gatk-launch"


Sign In or Register to comment.