To celebrate the release of GATK 4.0, we are giving away free credits for running the GATK4 Best Practices pipelines in FireCloud, our secure online analysis portal. It’s first come first serve, so sign up now to claim your free credits worth $250. Sponsored by Google Cloud. Learn more at https://software.broadinstitute.org/firecloud/documentation/freecredits

--cosmic option for Mutect2 in GATK 4.0 beta version?

Hi, What is the current option for "--cosmic" in Mutect2 tool name under GATK 4.0 beta version?

I am trying to call variants in a panel of unmatched normals.

Thank you.

Tagged:

Answers

  • SheilaSheila Broad InstituteMember, Broadie, Moderator

    @Bhakti
    Hi,

    There is no use of Cosmic in GATK4. Have a look at the latest presentations and tutorials on Mutect2. They are in the presentations section.

    Also, have a look at this thread.

    -Sheila

  • Thanks.

    I was able to run Mutect2 using the below command.

    ./gatk-launch --javaOptions -Xmx12G Mutect2 -R $ref_fasta -I normal3.bam -D $DBSNP -tumor Normal3 -O output.normal3.vcf

    I am trying to a create a PON; however, the output vcf file is completely empty. All reads seems to be filtered out; for instance:

    "Mutect2 - 43410531 read(s) filtered by: (((((((((((MappingQualityReadFilter AND MappingQualityAvailableReadFilter) AND MappingQualityNotZeroReadFilter) AND MappedReadFilter) AND PrimaryAlignmentReadFilter) AND NotDuplicateReadFilter) AND PassesVendorQualityCheckReadFilter) AND NonZeroReferenceLengthAlignmentReadFilter) AND ) AND MateOnSameContigOrNoMappedMateReadFilter) AND GoodCigarReadFilter) AND WellformedReadFilter)"

    Help please? Thank you

  • @Sheila

    Thanks.

    I was able to run Mutect2 using the below command.

    ./gatk-launch --javaOptions -Xmx12G Mutect2 -R $ref_fasta -I normal3.bam -D $DBSNP -tumor Normal3 -O output.normal3.vcf

    I am trying to a create a PON; however, the output vcf file is completely empty. All reads seems to be filtered out; for instance:

    "Mutect2 - 43410531 read(s) filtered by: (((((((((((MappingQualityReadFilter AND MappingQualityAvailableReadFilter) AND MappingQualityNotZeroReadFilter) AND MappedReadFilter) AND PrimaryAlignmentReadFilter) AND NotDuplicateReadFilter) AND PassesVendorQualityCheckReadFilter) AND NonZeroReferenceLengthAlignmentReadFilter) AND ) AND MateOnSameContigOrNoMappedMateReadFilter) AND GoodCigarReadFilter) AND WellformedReadFilter)"

    Help please? Thank you

  • SheilaSheila Broad InstituteMember, Broadie, Moderator

    @Bhakti
    Hi,

    So, you are saying the output of Mutect2 on just normal samples is empty? If so, how did you pre-process your BAM files and what kind of data are you working with? Please also post the exact log output from the Mutect2 run.

    Thanks,
    Sheila

  • @Sheila

    Yes. I have generated the alignment files using STAR aligner, marked the duplicates using picard, addOrReplaceReadGroups, and then sorted the bam files. I am using transcriptome data.

  • SheilaSheila Broad InstituteMember, Broadie, Moderator

    @Bhakti
    Hi,

    Hmm. Looking at the filter status, it looks like your reads are badly mapped. Can you post some IGV screenshots of sites where you think variants should be called? Do the reads have good mapping qualities/base qualities?

    Thanks,
    Sheila

  • @Shiela,

    I fixed the problem. It is the nature of the data type i.e, transcriptome data and STAR aligner --outSAMmapqUnique option. One of the previous post on GATK helped resolved the issue.

  • @Sheila

    I fixed the problem. It is the nature of the data type i.e, transcriptome data and STAR aligner --outSAMmapqUnique option. One of the previous post on GATK helped resolved the issue.

  • SheilaSheila Broad InstituteMember, Broadie, Moderator

    @Bhakti
    Hi,

    Wonderful news! If you can post the thread that ultimately helped you, it may help other users too :smiley:

    -Sheila

Sign In or Register to comment.