We've moved!
You can find our new documentation site and support forum for posting questions here.

How can I write to the sample level using a pair level method?

I heard this was working before using: this.sample.attribute but I seem to be getting an error saying : "Failed at line 1, identifier part expected." Is this maybe due to the recent update? Thanks!


Best Answer


  • KateNKateN Cambridge, MAMember, Broadie, Moderator admin

    The update should not have affected this aspect of FireCloud. Using the "Share" button in FireCloud, please share your workspace with [email protected]. I'll also need the name of your method configuration where you are encountering this error.

  • Thanks @KateN, I have shared the workspace SC_methods_testing with the group you mentioned and the method is called ConvertBedToTargetFile_for_pairs

  • KateNKateN Cambridge, MAMember, Broadie, Moderator admin

    Unfortunately I am unable to access the workspace you've shared with me, as it has an authorization domain attached to it. I'm working with some developers to see what we can suggest to do from here.

    In the meantime, can you confirm that the method does have the pair entity set? Also check that the data tables have the column names you expect (pair table should have case_sample, and the sample table should have gatk4cnv_target_tsv_capture).

  • @KateN I can confirm that the method has the pair entity set, has case_sample and control_sample in the pair entity metadata, as well as gatk4cnv_target_tsv_capture in the sample metadata. Let me know if if you have any ideas or have office hours I can come to!

  • KateNKateN Cambridge, MAMember, Broadie, Moderator admin

    Alright, I think the best option for you would be to attend office hours tomorrow. They are Wednesdays in Yosemite (4001) from 2-3 pm. There will be at least one developer there able to help you troubleshoot in person.

  • @KateN Unfortunately I couldn't make this Wednesday's office hours--will this be a weekly occurence?

  • bshifawbshifaw Member, Broadie, Moderator admin

    That's right, our office hours are held every week!

  • Tiffany_at_BroadTiffany_at_Broad Cambridge, MAMember, Administrator, Broadie, Moderator admin

    @cheungatm Do you have the ability to add one of our team members or [email protected] to the authorization domain to investigate? If so, we can help you sooner.

  • @Tiffany_at_Broad according to the permissions settings, it looks like the [email protected] should at least have READER access for cmi-met-prostate-project/SC_methods_testing. Can you not access the workspace at all on your end? I can bump it up to OWNER or WRITER access level if necessary.

  • bshifawbshifaw Member, Broadie, Moderator admin

    You can share a regular workspace with others by clicking the share icon on the top left of the workspace summary tab. However, if the workspace was created under an authorization domain then the users will also need to be added to that domain.
    Currently we are receiving the following message when accessing your workspace:

    Tiffany may be asking whether you can add [email protected] to the vanallenlab domain group

  • Sorry, I'll need to ask my PI about any restrictions on these data but either way I'll come to office hours this week to sort it out with you folks!

  • @bshifaw You've been added to the authorization domain, so please let me know if you see any obvious issues with my method when you get the chance

  • bshifawbshifaw Member, Broadie, Moderator admin

    I couldn't find any problems with the way you entered the name in your method configuration. I wasn't able to evaluate the method because FC mentions that the method was redacted but this might be due security. As the method may have been marked private when sharing the workspace. So office hours may still be the best option.

    Side note. If you would like to check if method configurations were correctly set you can use Evaluate entity expression in FC's swagger api page. I checked your entity expression this.case_sample.gatk4cnv_target_bed_capture with one of the pairs in the data model and obtained a bed file, so the expression seems to work.

  • bshifawbshifaw Member, Broadie, Moderator admin

    If you would like me to check anything else just let me know but if not please remove me from the Authorization Domain Group.

    Also, if your blocked by running this workflow you could remove output expression entities. The workflow would still run but you would need to use the monitor tab to locate output files for the submitted job.

  • KateNKateN Cambridge, MAMember, Broadie, Moderator admin

    @cheungatm If Beri's suggestions did not solve your issue and you would still like to go to office hours, this week's office hours have been moved to Kalahari. It will be at the same time, and next week's office hours will be back to its usual location.

Sign In or Register to comment.