Heads up:
We’re moving the GATK website, docs and forum to a new platform. Read the full story and breakdown of key changes on this blog.

Method configurations are not loading (Server Unavailable error)

Hello Firecloud Team,

I started to see the same error for the past few days when trying to access method configurations in the method repository. It takes awhile to load configurations but then this error appears. I attached the snapshot of it. Once in a while it goes through and I am able to view configurations.

As always thank you for your help and support!
Luda.

Best Answer

  • lelaginalelagina
    Accepted Answer

    No, I have not encountered these errors as well. However they disappeared couple days prior to the new patch release. So maybe it was resolved by something else. I am not sure what though.

Answers

  • KateNKateN Cambridge, MAMember, Broadie, Moderator admin

    Hello @lelagina,

    I see in your screenshot that you were hitting this error at a time when FireCloud was down. We are aware of an outage that occurred recently, but to my knowledge FireCloud should be working correctly now. Could you verify whether or not you are still seeing this error?

  • lelaginalelagina Member, Broadie

    Hello Kate,

    This screenshot is taken few second ago.

    Let me know if you there is any other information I can provide.

    Thank you,
    luda.

  • KateNKateN Cambridge, MAMember, Broadie, Moderator admin
    edited August 2018

    Alright, in testing it on my own computer, I'm able to access random method configurations in the repository. I don't have access to your specific method configuration, so it may have something to do with your specific config.

    Before I ask you to share it, could you try clearing your browser's cache and cookies? Be sure to close your browser completely and then reopen it before trying to access that page again.

    If that still doesn't work, then please share your method using the "Permissions" button with [email protected] and [email protected]. Ordinarily I'd ask you to share it with our support group, but group sharing is not implemented for methods yet. These two email addresses are myself, and a developer who would be involved in helping to troubleshoot.

  • lelaginalelagina Member, Broadie

    We had issue with parsing wdl for this workflow before. Please see this thread: https://gatkforums.broadinstitute.org/firecloud/discussion/12381/significant-slow-down-of-firecloud#latest. I believe it could be related.

    I did what you asked me and still get the same error. As you said I also do not have issue loading any other method configurations, just this particular workflow.

  • KateNKateN Cambridge, MAMember, Broadie, Moderator admin

    Ah, it might have something do to with the size of your specific method config. I'm looping in some of our developers to see where we should go from here.

  • lelaginalelagina Member, Broadie

    Hi Kate,

    Is it the number of inputs and outputs that causing this error? I have 43 inputs and around 150 outputs.
    Or there is another issue?

    Thank you,
    Luda.

  • KateNKateN Cambridge, MAMember, Broadie, Moderator admin

    I'm not sure, but a developer would like to take a look into the method config itself. Please share your method using the "Permissions" button with [email protected]. Ordinarily I'd ask you to share it with our support group, but group sharing is not implemented for methods yet.

    If it is the number of inputs & outputs, we want to find that out so that we can fix it.

  • lelaginalelagina Member, Broadie

    Hello Kate,

    I already did that when you asked me to do it yesterday.

    "If that still doesn't work, then please share your method using the "Permissions" button with [email protected] and [email protected] Ordinarily I'd ask you to share it with our support group, but group sharing is not implemented for methods yet. These two email addresses are myself, and a developer who would be involved in helping to troubleshoot."

  • KateNKateN Cambridge, MAMember, Broadie, Moderator admin

    Hm. That's odd, I can't seem to find the method. Can you confirm that the method is lelagina/CGA_Production_Analysis_Pipeline_WES? Is the permission level set to Reader for the users you shared it with?

  • lelaginalelagina Member, Broadie

    Hello Kate,

    Can you check now?

    Thank you,
    Luda.

  • KateNKateN Cambridge, MAMember, Broadie, Moderator admin

    I have access, thank you! I'm passing this information on to a developer now to take a look.

  • KateNKateN Cambridge, MAMember, Broadie, Moderator admin
    edited August 2018

    Looking in the screenshot, you are seeing issues with loading the method configs themselves. I thought sharing the method would share with us the published configs, so that's my mistake.

    To be able to test the issue out, you would need to access the large method configuration from within a workspace. On that method config page, there's a new link:

    Click Download .json file, and please send that file to me. If you can attach it to this thread, please do that. Otherwise you can direct message me on the forum with it. You may need to change the file ending to .txt.

  • lelaginalelagina Member, Broadie

    Hello Kate,

    I attached the inputs file. Let me know if you have any issue accessing it.

    Thank you,
    Luda.

  • Tiffany_at_BroadTiffany_at_Broad Cambridge, MAMember, Administrator, Broadie, Moderator admin

    Hi @lelagina I am filling in for Kate today. Anu will be taking a look at this and report back later this afternoon. Are you blocked from running an analysis?

  • lelaginalelagina Member, Broadie

    Hello Tiffany,

    It has been one hour since I submitted my job and it is still in Queued in Cromwell.

    Thank you,
    Luda.

  • Tiffany_at_BroadTiffany_at_Broad Cambridge, MAMember, Administrator, Broadie, Moderator admin

    Hi Luda,

    Thanks for letting us know. As you can see, Cromwell, the workflow engine, is running into capacity issues. We are investigating ways of increasing our current capacity.

  • ansinghansingh Member

    @lelagina Hi - I'm investigating your issue regarding not being able to see the published configs of your method - I am unfortunately unable to reproduce your error myself with the information I currently have. But, if I was able to shoulder surf, it would be much easier to diagnose your error. Do you have time to meet on Monday?

  • lelaginalelagina Member, Broadie

    I have not experienced this issue with loading configurations in the last couple days.
    Not certain the exact fix in Firecloud resolved it. But I will keep you posted in case I encounter it again.

    Thank you,
    Luda.

  • ansinghansingh Member

    @lelagina We also released a patch for slow-to-load method configs yesterday that may alleviate that issue. Are you still seeing server errors when loading that page?

  • lelaginalelagina Member, Broadie
    Accepted Answer

    No, I have not encountered these errors as well. However they disappeared couple days prior to the new patch release. So maybe it was resolved by something else. I am not sure what though.

Sign In or Register to comment.