Holiday Notice:
The Frontline Support team will be offline December 17-18 due to an institute-wide retreat and offline December 22- January 1, while the institute is closed. Thank you for your patience during these next few weeks as we get to all of your questions. Happy Holidays!

Latest Release: 12/4/18
Release Notes can be found here.

Updating data model and method configuration outputs do not appear in data model after execution

akmanningakmanning United StatesMember

I'm having problems updating the data model in a workspace.

Specifically, I'm trying to update Sample attributes (add columns to the data model) through
(1) an "update:sample_id" tsv file, which doesn't work to add columns, although existing attributes have updated attribute values.
- screen shots (tiff files) are attached to this question.

(2) through executing a method configuration: although the correct outputs exist in the execution log, new columns are not appearing in the data model.

Answers

  • birgerbirger Member, Broadie, CGA-mod ✭✭✭

    We don't currently support adding new columns to an entity model through TSV files. I'll add to the FireCloud product backlog a request to add that capability.

    Your item (2), however, should work. Did you check your column display filter widget (upper left hand corner of the table display). Does it display the new column? If so, is it checked for display?

  • akmanningakmanning United StatesMember

    The column display widget does not display the new columns.

    When I run a workflow through an associated method config (on a sample in the data model), the output is not being written to a new attribute in the data model.

    When I removed the "this." in the method configuration on the outputs, the appropriate attributes were added to the workspace. So outputs can be mapped to a workspace attribute, I just can't get it into the Sample attributes.

  • birgerbirger Member, Broadie, CGA-mod ✭✭✭

    Alice, would you mind sharing your workspace with me ([email protected])? Just give me read access, I'll clone it and then run my tests on the clone. Thanks.

  • akmanningakmanning United StatesMember

    Here are screen shots showing the problem. Let me know what I'm doing wrong. :-) (Sharing workspace, too)

  • birgerbirger Member, Broadie, CGA-mod ✭✭✭

    Alice...I'm told this is functionality that we did have in the past. A bug must of been introduced that broke this functionality. Regressions get top priority so it should be fixed soon. We'll let you know when it is available. I will run some tests on a clone of your workspace regardless. Thanks.

  • birgerbirger Member, Broadie, CGA-mod ✭✭✭

    Alisa,

    Regarding issue (1), could you attach your TSV files...I'd like to test them? I ran some tests in a workspace of my own creation and found that the data model is, in fact, getting updated with the new column; the GUI, however, was not displaying it. When I refreshed the page in which I was viewing the data table that I had added a column to (participants in my case), the new column appeared (both on the table view and in the column display widget).

    I suspect issue (2) may be similar. Please see if the new columns appear if you refresh the page after running the workflow.

Sign In or Register to comment.