Latest Release: 02/19/19
Release Notes can be found here.

String literals cannot be set to empty string

Hi Firecloud Team,

When I try to run recapseg, I want to set both

recapseg_workflow.recapseg_tumor_pcov.is_plotting: (String)

and

recapseg_workflow.recapseg_tumor_pcov.no_pon_reduction: (String)

to false in my task configuration.

They are both flags, when they are true they are set to "--is-plotting" etc.
When they are false, they should be set to empty string ""

When I try that (or several spaces etc.), it always converts it to "No value entered" and fails to launch the analysis because the value is not set.

Best Answer

Answers

  • dlivitzdlivitz Member, Broadie
    edited February 2016

    Also, I tried to make workspace annotation a string of spaces " ", which worked, but when I set the value to workspace.empty_string it parses it, and says "no value entered"

    Correction - this worked, but the method configuration was permanently glitched, and would not let me set the string parameters. When I configured from scratch with workspace.empty_string it was fine.

    I have published a configuration of broken recapseg, try to import dlivitz/broken_recapseg and edit the not set string literals to reproduce.

    Post edited by dlivitz on
  • jneffjneff BostonMember, Broadie, Moderator admin

    Hi Dimitri,

    I'd like to chat tomorrow if you have a moment. I'm in the process of documenting literals values for method configurations, including strings and boolean true/false. Viewing your method configuration may help me create a good example. I can also try to coordinate a response to any issues you are still experiencing.

    -Jason

Sign In or Register to comment.