SSL Error pushing WDLs

danielrdanielr Broad InstituteMember, Broadie

This issue has already been resolved, but in case anyone else has the same issue, I wanted to post it to the forum. When trying to push a WDL to the method repository from my local machine, I get the following error message

[SSL: TLSV1_ALERT_PROTOCOL_VERSION] tlsv1 alert protocol version (_ssl.c:590)
Could not connect to https://firecloud.dsde-prod.broadinstitute.org/service/api/methods with method POST

One way to fix this problem is to use the dockerized version in the readme (https://github.com/broadinstitute/firecloud-cli). If there are other workarounds, please post!

Best Answer

Answers

  • jneffjneff BostonMember, Broadie, Moderator admin

    Hi Daniel. Thank you for posting this. Eddie Salinas is testing another workaround that uses a recent version of openssl. Please stay tuned.

  • esalinasesalinas BroadMember, Broadie ✭✭✭

    Note, it should be CPPFLAGS and LDFLAGS ...
    NOT two settings of LDFLAGS!

    wm8b1-75c:Python-2.7.11 esalinas$ export CPPFLAGS=-I/usr/local/ssl/include/
    wm8b1-75c:Python-2.7.11 esalinas$ export LDFLAGS=-L/usr/local/ssl/lib/

    sorry for the mistake!

    -eddie

  • esalinasesalinas BroadMember, Broadie ✭✭✭

    In addition to making sure that the python loads a sufficiently new SSL, another alternative/idea is to use the firecloud CLI container. See https://github.com/broadinstitute/firecloud-cli

Sign In or Register to comment.