"cannot import name Timestamp" ggplot pandas

bshifawbshifaw Member, Broadie, Moderator admin

I'm getting the following error in a notebook.

ImportErrorTraceback (most recent call last)
<ipython-input-6-34dfeaf0e457> in <module>()
      2 import pandas as pd
      3 from StringIO import StringIO
----> 4 from ggplot import *

/usr/local/lib/python2.7/dist-packages/ggplot/__init__.py in <module>()
     18 
     19 from .geoms import geom_area, geom_blank, geom_boxplot, geom_line, geom_point, geom_jitter, geom_histogram, geom_density, geom_hline, geom_vline, geom_bar, geom_abline, geom_tile, geom_rect, geom_bin2d, geom_step, geom_text, geom_path, geom_ribbon, geom_now_its_art, geom_violin, geom_errorbar, geom_polygon
---> 20 from .stats import stat_smooth, stat_density
     21 
     22 from .facets import facet_wrap, facet_grid, Facet

/usr/local/lib/python2.7/dist-packages/ggplot/stats/__init__.py in <module>()
      1 from .stat_density import stat_density
----> 2 from .stat_smooth import stat_smooth

/usr/local/lib/python2.7/dist-packages/ggplot/stats/stat_smooth.py in <module>()
      3 
      4 from ..geoms.geom import geom
----> 5 from . import smoothers
      6 from ..utils import is_date
      7 

/usr/local/lib/python2.7/dist-packages/ggplot/stats/smoothers.py in <module>()
      2                         unicode_literals)
      3 import numpy as np
----> 4 from pandas.lib import Timestamp
      5 import pandas as pd
      6 import statsmodels.api as sm

ImportError: cannot import name Timestamp

when running the following command

import firecloud.api as fc
import pandas as pd
from StringIO import StringIO
from ggplot import *

The following stack overflow thread mentions this is due to version descriprences in panda and shows how to fix it but not in Jupyter. How can i fix this error in Jupyter?

Best Answers

Answers

Sign In or Register to comment.