We've moved!
You can find our new documentation site and support forum for posting questions here.

Permission to upload and delete files in google bucket


I used to be able to upload and delete files in my google bucket, but recently there seems to have been a change in user permissions, and now I am no longer able to upload/delete files from my computer, but I can still do that through ssh and Google-Cloud-SDK.

The specific bucket is fc-733ca028-212e-4aa6-9448-c1691fc9132f. Could you please grant permission?

Thank you very much!


Best Answers


  • Hi,

    I have the same problem as Julia above. Thinking a little further, as well.

    Issue 1. To link a billing account to FireCloud, it must be newly created inside FireCloud. I have tried using my existing GCP billing account and the interface just hangs. I would prefer to just keep my .bams in my main billing account bucket and reference from FC. I tried this previously and it failed to access the data. (Maybe I specified the data wrong in the Configuration, so I'll check again.)

    Issue 2. When I create the FC billing account, I don't have permission to create buckets. I believe I had the ability previously to upload files to the buckets - at least inside a bucket created by a workspace - but can't now.

    Request 1 - Please give permission to access data in external GCP buckets from FC Configurations.
    Request 2 - Please allow use of existing GCP billing projects inside FC. If we view FC as an application running on GCP, and since FC charges nothing, this would be the easiest way. Otherwise we have to have two billing accounts - outside FC and inside FC.
    Request 3 - Please allow ability to create buckets within the force-created FC billing project.

    There may be policy reasons that these are not possible but I don't currently understand the policy.

    Thanks and anxiously awaiting, Mike D'

  • KateNKateN Cambridge, MAMember, Broadie, Moderator admin

    Hello @JuliaJoung and @mikedamour. I'm looping in a colleague to investigate your issue, and she will speak with the team as to whether or not the permissions you've requested are possible.

  • JuliaJoungJuliaJoung Member, Broadie


    In that case could you add my FC project's service account to my GCP bucket's data? I looked around but do not seem to have the permission to do this.

    Thank you!


  • SChaluvadiSChaluvadi Member, Broadie, Moderator admin

    @JuliaJoung - I will look into why these permission issues persist and get back to you. Can you confirm if the google bucket in question is a FireCloud workspace bucket or a non FireCloud associated bucket?

  • SChaluvadiSChaluvadi Member, Broadie, Moderator admin

    @JuliaJoung As we haven't heard back from you, we will at this time be closing this ticket. Don't hesitate to follow up with any issues that you may have and we are more than happy to take a second look!

Sign In or Register to comment.