Error running Mutect2

@bshifaw
I have been running Mutect2_gatk4 on the firecloud for tumor-normal samples. I successfully ran the analyses on some of the samples. But for two of my samples, I got an error message saying "Job Mutect2.M2:49:1 exited with return code 1 which has not been declared as a valid return code. See 'continueOnReturnCode' runtime attribute for more details." One of them was on call 51 and the other was on call 55. I am not quite sure what this error means. I was wondering if you might be able to help me with this?

Best Answers

Answers

  • bshifawbshifaw moonMember, Broadie, Moderator admin

    Hi @pkhadka

    Your question was moved to the FireCloud forum.
    Would you mind sharing your workspace with [email protected] and tell us the name of the workspace as well as any submission and workflow ids involved.

  • pkhadkapkhadka Member
    edited September 2018

    @bshifaw I shared the workspace with the firecloud support group. I reran the analysis on these two samples again and still got the same error. The name of my workspace is fccredits-sulfur-copper-9549/Cranio Project
    And the submission IDs for the failed analyses are:
    fa653297-0187-46fa-8a1c-ab81ca92e9ea
    0bad0e39-be9f-4bbc-a25c-b7b236504923

    Thanks!

  • bshifawbshifaw moonMember, Broadie, Moderator admin

    Looks like the workspace is Authorization Domain protected. I've requested access.

  • bshifawbshifaw moonMember, Broadie, Moderator admin

    @pkhadka Gaining access is taking a while.
    Can you share the stderr, stdout, and JessLog files of the failed call.
    The following Troubleshooting document may help identify the files.

  • pkhadkapkhadka Member

    @bshifaw do you have the access now? I tried to upload the files here but it didn't let me do it bc the file type is not supported.

  • bshifawbshifaw moonMember, Broadie, Moderator admin

    No, still don't have access. The files are just text. Try changing the extension to .txt then upload the files.

  • pkhadkapkhadka Member

    @bshifaw I asked my PI again to give you access to it. I have attached stderr and JESLog file here. stdout file was empty.

  • bshifawbshifaw moonMember, Broadie, Moderator admin

    The stderr file indicates the error is related to an extended index, perhaps associated with the scatter for M2 task. I'll need to refer to someone on the dev team.

    [September 6, 2018 5:15:47 AM UTC] org.broadinstitute.hellbender.tools.walkers.mutect.Mutect2 done. Elapsed time: 356.84 minutes.
    Runtime.totalMemory()=1936105472
    java.lang.StringIndexOutOfBoundsException: String index out of range: 379
        at java.lang.String.substring(String.java:1963)
        at org.broadinstitute.hellbender.tools.walkers.annotator.ReferenceBases.annotate(ReferenceBases.java:48)
        at org.broadinstitute.hellbender.tools.walkers.annotator.VariantAnnotatorEngine.annotateContext(VariantAnnotatorEngine.java:270)
        at org.broadinstitute.hellbender.tools.walkers.mutect.SomaticGenotypingEngine.callMutations(SomaticGenotypingEngine.java:176)
        at org.broadinstitute.hellbender.tools.walkers.mutect.Mutect2Engine.callRegion(Mutect2Engine.java:211)
        at org.broadinstitute.hellbender.tools.walkers.mutect.Mutect2.apply(Mutect2.java:212)
        at org.broadinstitute.hellbender.engine.AssemblyRegionWalker.processReadShard(AssemblyRegionWalker.java:291)
        at org.broadinstitute.hellbender.engine.AssemblyRegionWalker.traverse(AssemblyRegionWalker.java:267)
        at org.broadinstitute.hellbender.engine.GATKTool.doWork(GATKTool.java:979)
        at org.broadinstitute.hellbender.cmdline.CommandLineProgram.runTool(CommandLineProgram.java:137)
        at org.broadinstitute.hellbender.cmdline.CommandLineProgram.instanceMainPostParseArgs(CommandLineProgram.java:182)
        at org.broadinstitute.hellbender.cmdline.CommandLineProgram.instanceMain(CommandLineProgram.java:201)
        at org.broadinstitute.hellbender.Main.runCommandLineProgram(Main.java:160)
        at org.broadinstitute.hellbender.Main.mainEntry(Main.java:203)
        at org.broadinstitute.hellbender.Main.main(Main.java:289)
    
  • pkhadkapkhadka Member

    @bshifaw I will try doing that. Will let you know if it works. Thanks!

  • pkhadkapkhadka Member

    @bshifaw just to confirm, I created the attached tsv file and uploaded it to my workspace attribute. And then I referenced that in my method config for extra_args. Is that correct?

  • bshifawbshifaw moonMember, Broadie, Moderator admin

    No need to create a file. The m2_extra_args is expecting a string so you can add in the "-XA ReferenceBases" for its attribute column and be sure to include quotations.

  • pkhadkapkhadka Member

    @bshifaw it didn't work and both tasks failed.

  • bshifawbshifaw moonMember, Broadie, Moderator admin

    I don't have access to the workflow so please post the stderr, stdout, and JessLog for the failed tasks.

  • pkhadkapkhadka Member

    There were many calls that failed and I can't open stderr, stdout and JESLog for some of these because it gives me error while opening. I have attached one of them that I was able to open. I have also attached a screenshot of the summary that I get for the failure.

  • pkhadkapkhadka Member

    @bshifaw this solved the problem. Thank you for helping me troubleshoot this!

Sign In or Register to comment.