FireCloud Error: rnaseq-germline-snps-indels

I was trying to run the method rnaseq-germline-snps-indels, cloned from the workspace help-gatk/rna-seq-germline-snps-indels, on some of my RNAseq samples, and all except one failed at the RNAseq.SplitNCigarReads step. The stderr files show the following error message:

"An error occurred because you did not provide enough memory to run this program. You can use the -Xmx argument (before the -jar argument) to adjust the maximum heap size provided to Java. Note that this is a JVM argument, not a GATK argument."

I don't see any variable named Xmx in the inputs of the method configuration, so I suppose the error message is asking to modify the WDL file. Can you please tell me which line(s) of the WDL file need to be edited? And how much memory would be enough to run this program (my largest bam file is 12GB)?

Best Answers

  • anshumananshuman NJ
    Accepted Answer

    It worked: editing the WDL file to increase memory, in the way you suggested, resolved the issue.

Answers

  • bshifawbshifaw Member, Broadie, Moderator admin

    Hi @anshuman

    We don't offer a guide for determining the memory requirements for your workflow, much of this is trial and error.
    Be sure to change the memory in the runtime block if you plan to set the -xmx option to larger than 4GB. The java heap size should not be larger than the VM memory size set in the runtime block.
    For more examples on the use of -xmx in a gatk3 workflow, view the gatk3-data-preprocessing workflow

  • anshumananshuman NJMember

    Hi @Tiffany_at_Broad and @bshifaw

    Thanks for your helpful suggestions. It seems the "Edit Configuration" feature does not allow users to edit the WDL file. Is there another way of editing the WDL file of a method in FireCloud?

  • bshifawbshifaw Member, Broadie, Moderator admin

    Ah, yes.
    In order to edit the WDL you'll need to clone a copy of the workflow, edit your clone to increase the memory, then use your cloned edited version in your workspace.

  • anshumananshuman NJMember
    Accepted Answer

    It worked: editing the WDL file to increase memory, in the way you suggested, resolved the issue.

Sign In or Register to comment.