Heads up:
We’re moving the GATK website, docs and forum to a new platform. Read the full story and breakdown of key changes on this blog.

Workflow failures

kanderkakanderka BroadMember, Broadie

Some of my samples failed the first time I ran them through an analysis workflow so I restarted them, and now some are still failing with this error:
ErrorReport(rawls,http error calling uri https://cromwell1.dsde-prod.broadinstitute.org:443/api/workflows/v1/batch,Some(500 Internal Server Error),List(),List(),None)

I can restart again but wanted to check in with you guys to make sure I wouldn't get the same error again...

Answers

  • KateNKateN Cambridge, MAMember, Broadie, Moderator admin

    Thank you for your report. Unfortunately that's a rather generic error, so I'm consulting with the developers to get further guidance. I will let you know your next steps once I have something concrete for you.

  • KateNKateN Cambridge, MAMember, Broadie, Moderator admin

    Alright, I think I'll need to take a look at the actual workspace itself. Could you please share the workspace with [email protected], and give the name of the workspace, the submission ID and the workflow ID here.

  • KateNKateN Cambridge, MAMember, Broadie, Moderator admin

    Hi @kanderka, thank you so much for your patience. As you may have noticed the week you were launching those submissions, we were experiencing intermittent outages. With the last release on March 28th, we have updated our Cromwell execution engine, and we haven't seen more of these outages since. Given the timing, it likely that Cromwell was down or struggling when you were launching your submissions. If you try re-running the workflow it should complete without hitting that error.

  • kanderkakanderka BroadMember, Broadie

    Thanks, @KateN! I'll try it again

Sign In or Register to comment.