Heads up:
We’re moving the GATK website, docs and forum to a new platform. Read the full story and breakdown of key changes on this blog.

Failed to localize files error

I am trying to run amaro/pick_absolute_solution in the Wu_DCIS_WES_analysis workspace but keep getting variants of "Failed to localize files", see below for an example:

Please see https://portal.firecloud.org/#workspaces/broad-firecloud-wuclonal/Wu_DCIS_WES_analysis/monitor/8e3e1d74-5ff4-4a90-b036-abdd4750bb3f/68280dec-f3a5-4ec3-a1ad-0ed8fdc1ae11

The required input files are all there. Could you please help? I have run it several times with no luck.

Best Answer

Answers

  • KateNKateN Cambridge, MAMember, Broadie, Moderator admin
    edited January 2018

    Usually the Failed to localize files error doesn't mean that your files were unable to be localized, but that something prevented the system from finding the files. This can range from something as simple as your workflow not running properly (and thus the files not being generated), to a more complicated bug. The latter is not very common.

    Could you please share the workspace you linked above with [email protected] so I can take a look?

  • sassas Member

    I have given you access to the workspace. Getting the same error in another workspace, would be really useful to figure out what's going on. Thanks.

  • KateNKateN Cambridge, MAMember, Broadie, Moderator admin
    edited January 2018

    As I do not have access to your google bucket to check, could you please see that:

    gs://fc-a78394ea-a802-4073-8780-934eb6fd810e/87d83ee3-2986-4bf5-81d8-7b137d9f057c/Clinical_Workflow/19857089-505d-427e-9fbe-6ce371545be5/call-gatk_acnv_only/attempt-2/RP-1379_Case2_IDC.seg

    Does in fact exist in the bucket itself? This appears to be an input from another workflow, which I'm assuming is being fed into this workflow. I'm unable to check this as the method itself appears to be redacted.

    If the file does exist, it might be that the person running the workflow does not have access to the bucket. Double check that as well--If they can look at the file at the above URL, then they do have access.

    I'm also having developers look at this case, but I want to be sure that the simple solutions are addressed first.

  • sassas Member

    Kate,

    It seems that I mistakenly sent you the link to an older run where the bucket path that you specified actually does not exist (the ''attempt-2' in the path is incorrect).

    To keep things clean I have rerun the pick_absolute_solution task separately on the same pair (RP-1379_Case2_IDC) and got the sample failed to delocalize files error:

    https://portal.firecloud.org/#workspaces/broad-firecloud-wuclonal/Wu_DCIS_WES_analysis/monitor/f194d497-ea35-425c-8195-cde0ee675bb9/29ecc43c-0801-41fe-9058-85e738e754bd

    The bucket paths of the input files are as follows:
    maf_file
    gs://fc-a78394ea-a802-4073-8780-934eb6fd810e/87d83ee3-2986-4bf5-81d8-7b137d9f057c/Clinical_Workflow/19857089-505d-427e-9fbe-6ce371545be5/call-mutation_validator/RP-1379_Case2_IDC.validated.maf
    pick_absolute_solution
    pp_modes_file
    gs://fc-a78394ea-a802-4073-8780-934eb6fd810e/87d83ee3-2986-4bf5-81d8-7b137d9f057c/Clinical_Workflow/19857089-505d-427e-9fbe-6ce371545be5/call-absolute/RP-1379_Case2_IDC.PP-modes.data.RData
    pick_absolute_solution
    seg_file
    gs://fc-a78394ea-a802-4073-8780-934eb6fd810e/87d83ee3-2986-4bf5-81d8-7b137d9f057c/Clinical_Workflow/19857089-505d-427e-9fbe-6ce371545be5/call-gatk_acnv_only/RP-1379_Case2_IDC.seg

    I confirm that all of these paths point to files that exist, and that I have access to them (I'm running the task).

    Thanks a lot for your help.

  • sassas Member

    Getting the same error in other workspaces. Would other examples of failure help with troubleshooting?

Sign In or Register to comment.