Ever wish you could automatically remove your unwanted output files from a submission without having to manually review them? If so, take this two minute survey and tell us more.
Latest Release: 1/10/19
Release Notes can be found here.

Does "Save As New Snapshot" still work in the Edit Method pop-up dialog?

ChipChip 415M 4053Member, Broadie

Hi

I've been attempting to update a workflow in FC stewart/SamtoFastq (simple picard conversion from bam to fastq files) but the "Save As New Snapshot" doesn't appear to do anything. As a clueless FC user I've done things like clean out my chrome cache, logged in and out of FC and chrome, as well as validating the new wdl using wdltool-0.14.jar (it validated) but "Save As New Snapshot" persistently does nothing.

Is there something else I'm forgetting to do?

Thanks,

Chip

Best Answer

Answers

  • KateNKateN Cambridge, MAMember, Broadie, Moderator admin

    There was a bug with this which we discovered and fixed around 10am EST this morning. Are you still seeing this issue?

  • ChipChip 415M 4053Member, Broadie

    Hmm. "Save As New Snapshot" still does nothing. I logged out/in of FC and tried again w/o success. Is there a way to make sure I'm getting the latest version?

  • KateNKateN Cambridge, MAMember, Broadie, Moderator admin

    I will ask the devs to see if there is any way to make sure you're updated. I would have thought that logging out and back in would fix it.

    Just to double check, what permission level do you have with the method? If it is Reader, that may be the reason you can't edit.

  • ChipChip 415M 4053Member, Broadie

    my email is displayed as the Method Owner:
    [email protected]

  • ChipChip 415M 4053Member, Broadie

    Out of frustration I tried making a new method with a different name that does the same thing as SamtoFastq. After pasting in the required fields of the "Create New Method" dialog, the "Upload" behaves much the same way as the "Save As New Snapshot" button does - nothing happens.

  • KateNKateN Cambridge, MAMember, Broadie, Moderator admin

    Yes, this does sound exactly like the bug we hit this morning. Our on-call developer would like to take a look. Could you share the method with her by setting [email protected] as an owner?

  • ChipChip 415M 4053Member, Broadie

    [email protected] is now an owner of stewart/SamtoFastq . A few minutes ago I tried doing this in Safari rather than Chrome and the "Save As New Snapshot" button worked ok. Is there something wrong with Chrome Version 61.0.3163.100 (Official Build) (64-bit) ?

Sign In or Register to comment.