Authorization exception... permission issue? or valid WDL/method name issue?

esalinasesalinas BroadMember, Broadie ✭✭✭
edited September 2017 in Ask the FireCloud Team

I try to upload a WDL, but I get this error message

Error: Authorization exception for user [email protected] attempting to exercise permission Create on entity broadinstitute_cga.WXS_hg19_MutationCalling_MuTect_v1-6_BETA.-1.
Hide Details
Code: 403
Occurred: September 5, 2017, 11:51 AM EDT

In the network tab , via inspection, I see

{
  "code": 403,
  "message": "Authorization exception for user [email protected] attempting to exercise permission Create on entity broadinstitute_cga.WXS_hg19_MutationCalling_MuTect_v1-6_BETA.-1.",
  "timestamp": 1504626716326
}

The permission error doesn't seem right because I'm an OWNER of the namespace:

Is this really a WDL method-name error/issue (such as invalid character in WDL name), but the permission issue is not really the issue?

Best Answers

Answers

  • esalinasesalinas BroadMember, Broadie ✭✭✭

    I found this release note link which points to an update to method naming rules

    https://software.broadinstitute.org/firecloud/blog?id=9868

    but it doesn't look like any character I have is invalid.

    I notice that there is a "-1" which I guess is a snapshot ID. I notice that it's negative one. Isn' that a system-generated number?

  • esalinasesalinas BroadMember, Broadie ✭✭✭

    I tried again this morning, and got another permission error message, the same message as before.

    I next tried again but with namespace="esalinas" (my username) and was successful in the WDL upload.

    So, it seems like I get a permission error even though I'm an OWNER on the namespace? I copied/pasted a screen crop/shot showing that I'm an OWNER.

  • esalinasesalinas BroadMember, Broadie ✭✭✭

    @birger is also an OWNER on the namespace. I showed him what was going on and he removed me from the namespace, then added me as READER for it, then finally made me OWNER. After that I tried again, but was unsuccessful with the same 403 error message.

  • esalinasesalinas BroadMember, Broadie ✭✭✭
    Accepted Answer

    @abaumann and I chatted at office hours and saw that the method already exists, but that I don't have OWNER on the method. @abaumann suggested that the error message has room for improvement.

Sign In or Register to comment.