The current GATK version is 3.7-0
Examples: Monday, today, last week, Mar 26, 3/26/04

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Did you remember to?


1. Search using the upper-right search box, e.g. using the error message.
2. Try the latest version of tools.
3. Include tool and Java versions.
4. Tell us whether you are following GATK Best Practices.
5. Include relevant details, e.g. platform, DNA- or RNA-Seq, WES (+capture kit) or WGS (PCR-free or PCR+), paired- or single-end, read length, expected average coverage, somatic data, etc.
6. For tool errors, include the error stacktrace as well as the exact command.
7. For format issues, include the result of running ValidateSamFile for BAMs or ValidateVariants for VCFs.
8. For weird results, include an illustrative example, e.g. attach IGV screenshots according to Article#5484.
9. For a seeming variant that is uncalled, include results of following Article#1235.

Did we ask for a bug report?


Then follow instructions in Article#1894.

Formatting tip!


Surround blocks of code, error messages and BAM/VCF snippets--especially content with hashes (#)--with lines with three backticks ( ``` ) each to make a code block.
Powered by Vanilla. Made with Bootstrap.
Picard 2.9.0 is now available. Download and read release notes here.
GATK 3.7 is here! Be sure to read the Version Highlights and optionally the full Release Notes.

Picard CollectOxoGMetrics

brofallonbrofallon Salt Lake City, UTMember Posts: 3

Hi there, I'm having trouble getting picard's CollectOxoGMetrics to produce output. Specifically, commands like:

java -Xmx2g -jar ~/tools/picard-tools-1.140/picard.jar CollectOxoGMetrics I=test.bam O=test.oxog.csv R=~/resources/GRCh38.p2.fa

produces a "test.oxog.csv" file with some header information including the command line arguments, etc., but no other content besides a few blank lines. No warning or error information is emitted, and other metrics commands seem to work just fine. I've tried a couple of different bams now (one in-house generated, one from Illumina) and got the same results for each one.
Am I missing something obvious?
Thanks!

Issue · Github
by Geraldine_VdAuwera

Issue Number
274
State
closed
Last Updated
Assignee
Array
Milestone
Array
Closed By
dekling

Best Answer

Answers

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie Posts: 11,414 admin

    Hi there, sorry for the delay -- your question slipped through our net. We'll get an answer to you tomorrow.

    Geraldine Van der Auwera, PhD

  • brofallonbrofallon Salt Lake City, UTMember Posts: 3

    Thanks - indeed it was the read group issue. Looks like CollectOxoGMetrics doesn't warn about this if no read group is specified. Thanks for the assistance!

Sign In or Register to comment.