The current GATK version is 3.7-0
Examples: Monday, today, last week, Mar 26, 3/26/04

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Did you remember to?


1. Search using the upper-right search box, e.g. using the error message.
2. Try the latest version of tools.
3. Include tool and Java versions.
4. Tell us whether you are following GATK Best Practices.
5. Include relevant details, e.g. platform, DNA- or RNA-Seq, WES (+capture kit) or WGS (PCR-free or PCR+), paired- or single-end, read length, expected average coverage, somatic data, etc.
6. For tool errors, include the error stacktrace as well as the exact command.
7. For format issues, include the result of running ValidateSamFile for BAMs or ValidateVariants for VCFs.
8. For weird results, include an illustrative example, e.g. attach IGV screenshots according to Article#5484.
9. For a seeming variant that is uncalled, include results of following Article#1235.

Did we ask for a bug report?


Then follow instructions in Article#1894.

Formatting tip!


Surround blocks of code, error messages and BAM/VCF snippets--especially content with hashes (#)--with lines with three backticks ( ``` ) each to make a code block.
Powered by Vanilla. Made with Bootstrap.
Picard 2.9.0 is now available. Download and read release notes here.
GATK 3.7 is here! Be sure to read the Version Highlights and optionally the full Release Notes.

memory used by DepthOfCoverage

chunxuanchunxuan Member Posts: 14

Hi,

I tried to use DepthOfCoverage to figure out the coverage of 50 whole exome sequencing data. It works fine for single sample, however, the program always complained about memory issue, even I provide 100 GB as "-Xmx100g". Any suggestions for the problem? There is a option "--read_buffer_size", which seems to be helpful, how should set the value ?

Tagged:

Best Answer

Answers

  • chunxuanchunxuan Member Posts: 14
    edited March 2014

    Some updates:

    The error output is

    OpenJDK 64-Bit Server VM warning: INFO: os::commit_memory(0x00007ff011600000, 2365587456, 0) failed; error='Cannot allocate memory' (errno=12)

    There is insufficient memory for the Java Runtime Environment to continue.
    Native memory allocation (malloc) failed to allocate 2365587456 bytes for committing reserved memory.

    java -version

    java version "1.6.0_26"

    Java(TM) SE Runtime Environment (build 1.6.0_26-b03)

    Java HotSpot(TM) 64-Bit Server VM (build 20.1-b02, mixed mode)

    Does anyone have similar problem?

  • chunxuanchunxuan Member Posts: 14

    @Geraldine_VdAuwera said:
    Hi chunxuan,

    DepthOfCoverage is very greedy for memory so running on 50 samples may be an issue, especially if you have areas of very high depth. Unfortunately there's nothing much we can do about that; the recommended way to deal with this is to run DoC separately on each individual sample and then analyze the results jointly using your preferred statistical package.

    A little bit update, do not assign too much memory by -Xmx, some times it will cause the memory issue.

Sign In or Register to comment.