The current GATK version is 3.7-0
Examples: Monday, today, last week, Mar 26, 3/26/04

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Did you remember to?

1. Search using the upper-right search box, e.g. using the error message.
2. Try the latest version of tools.
3. Include tool and Java versions.
4. Tell us whether you are following GATK Best Practices.
5. Include relevant details, e.g. platform, DNA- or RNA-Seq, WES (+capture kit) or WGS (PCR-free or PCR+), paired- or single-end, read length, expected average coverage, somatic data, etc.
6. For tool errors, include the error stacktrace as well as the exact command.
7. For format issues, include the result of running ValidateSamFile for BAMs or ValidateVariants for VCFs.
8. For weird results, include an illustrative example, e.g. attach IGV screenshots according to Article#5484.
9. For a seeming variant that is uncalled, include results of following Article#1235.

Did we ask for a bug report?

Then follow instructions in Article#1894.

Formatting tip!

Surround blocks of code, error messages and BAM/VCF snippets--especially content with hashes (#)--with lines with three backticks ( ``` ) each to make a code block.
Powered by Vanilla. Made with Bootstrap.
Picard 2.9.0 is now available. Download and read release notes here.
GATK 3.7 is here! Be sure to read the Version Highlights and optionally the full Release Notes.

don't understand multi sample snp calling format

kritikoolkritikool Member Posts: 20

I'm a little confused as to the format for multi sample snp calling suing Unified Genotyper. The example says:
-I sample1.bam [-I sample2.bam ...] \ but the presence of the dots is confusing.

Is the right format as in example a) or b) ?
a) -I sample1.bam [-I sample2.bam] [-I sample3.bam] [-I sample4.bam]
b) -I sample1.bam [-I sample2.bam sample3.bam sample4.bam]
I tried both ways and got error both times actually - "invalid argument "[-I"



Best Answer


  • kritikoolkritikool Member Posts: 20

    Thanks very much, much appreciate your response. If the original page could be edited to have the example like you have written here, I'm sure it would save much time and effort for a lot of people !

  • Geraldine_VdAuweraGeraldine_VdAuwera Administrator, Dev Posts: 11,163 admin

    Ok, we'll try to clarify this in the docs.

    Geraldine Van der Auwera, PhD

  • kritikoolkritikool Member Posts: 20
    edited February 2014

    I have a follow up question regarding this. Is the output by default a multi-sample VCF file , Or do I have to give as many "-o" output files as there are "-I" bam files.
    How do I convert this output to a multi-sample VCF file that I can use for association testing ?

    I tried multi-sample SNP calling with the following parameters and only got one sample in my VCF output:
    java -Xmx2g -jar /software/GenomeAnalysisTK-2.7-4-g6f46d11/GenomeAnalysisTK.jar \
    -R /gatk.ref/ucsc.hg19.fasta -T UnifiedGenotyper \
    -I sample1.bam -I sample2.bam -I sampl3.bam.....-I sample68.bam
    -o /multisample.vcf \
    -glm BOTH -nt 16 -U ALLOW_N_CIGAR_READS >>System.out 2>>System.err

    Post edited by kritikool on
  • Geraldine_VdAuweraGeraldine_VdAuwera Administrator, Dev Posts: 11,163 admin

    If you call multiple samples, you will get a single VCF with all the results. There is in fact no way to get a separate VCF for each sample.

    What you're seeing may be due to incorrect read group information; you should check the read group info in the headers.

    Geraldine Van der Auwera, PhD

  • kritikoolkritikool Member Posts: 20

    I give the same read group string to all samples before I run GATK. When I run single sample GATK on each sample, I have no trouble. But when running multi-sample SNP calling, I find that it just stops after chromosome 7, at which time the VCF file created so far is 50GB, but has only one sample info in it, and the vcf.idx is empty.
    Do you think its a memory issue that is causing the job to crash? Any recommendations ?

  • Geraldine_VdAuweraGeraldine_VdAuwera Administrator, Dev Posts: 11,163 admin

    I give the same read group string to all samples before I run GATK.

    If you give the same read group string, the GATK will think all the data belongs to one sample, and so it makes sense that you only see one sample reported in the VCF. Or am I misunderstanding something?

    It does sound like your jobs are not running to completion due to some memory error. Try increasing memory (use the java -Xmx argument) and see what happens.

    Geraldine Van der Auwera, PhD

Sign In or Register to comment.