The current GATK version is 3.7-0
Examples: Monday, today, last week, Mar 26, 3/26/04

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Powered by Vanilla. Made with Bootstrap.
GATK 3.7 is here! Be sure to read the Version Highlights and optionally the full Release Notes.
Register now for the upcoming GATK Best Practices workshop, Feb 20-22 in Leuven, Belgium. Open to all comers! More info and signup at

VariantsToTable - acces to BaseQRankSum or similar stats

rwaplesrwaples Seattle, WAMember Posts: 3

I'm having trouble accessing the INFO field "BaseQRankSum" when using VariantsToTable.

I cannot seem to acces this info. Other fields such as CHROM POS DP HET or even -GT fields work fine.

Example cmd line:
java -jar /home/ipseg/Programs/GATK/GenomeAnalysisTK-2.7-2-g6bda569/GenomeAnalysisTK.jar \
-T VariantsToTable \
-R '/olympus/DATA/PROJECTS/SNP DISCOVERY/EXOME CAPTURE/bowtie2/reference/cap3_contigs.fa' \
-V '/home/ipseg/Desktop/TEMP/GATK/variants.vcf' \
-F BaseQRankSum \

Every line is NA


Best Answer


  • rwaplesrwaples Seattle, WAMember Posts: 3
    edited October 2013

    I should note that this vcf was generated by GATK and has the header line:
    INFO=<ID=BaseQRankSum,Number=1,Type=Float,Description="Z-score from Wilcoxon rank sum test of Alt Vs. Ref base qualities">

    And I see the field within the VCF.
    Example containing line:

    ONTS_CLUSTER_ID#4216706_1254_1423|Contig1 70 . A T 955.77 . AC=1;AF=0.500;AN=2;BaseQRankSum=-1.510;ClippingRankSum=-0.170;DP=49;FS=1.298;MLEAC=1;MLEAF=0.500;MQ=59.45;MQ0=0;MQRankSum=-0.150;QD=19.51;ReadPosRankSum=-0.850 GT:AD:DP:GQ:PL 0/1:24,25:49:99:984,0,1936

  • rwaplesrwaples Seattle, WAMember Posts: 3

    Ok, this is a little wierd. I subsetted my .vcf file:
    -T SelectVariants \
    -fraction 0.005

    And got down to a few hundred variants (This a salmon exome capture project), re-ran the VariantsToTable with "-F BaseQRankSum" and it worked just fine, i get the BaseQRankSum statistic. Tried again on my full .vcf file with no luck. I tried subsetting with fraction 1.0 (bascially remaking .vcf) and again it worked just fine. I deleted the index file for the full vcf and re-ran VariantsToTable, with success!
    So thanks, but I think this was a once-of error in the index file. If can follow this up any more let me know.


  • Geraldine_VdAuweraGeraldine_VdAuwera Administrator, Dev Posts: 11,015 admin

    Hi Ryan, that's certainly odd; but if it's working now there's nothing I can really do to follow up. Thanks for reporting back, it's helpful for us to know that this symptom can be cause by an index blip.

    Geraldine Van der Auwera, PhD

Sign In or Register to comment.