The current GATK version is 3.7-0
Examples: Monday, today, last week, Mar 26, 3/26/04

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Get notifications!


You can opt in to receive email notifications, for example when your questions get answered or when there are new announcements, by following the instructions given here.

Did you remember to?


1. Search using the upper-right search box, e.g. using the error message.
2. Try the latest version of tools.
3. Include tool and Java versions.
4. Tell us whether you are following GATK Best Practices.
5. Include relevant details, e.g. platform, DNA- or RNA-Seq, WES (+capture kit) or WGS (PCR-free or PCR+), paired- or single-end, read length, expected average coverage, somatic data, etc.
6. For tool errors, include the error stacktrace as well as the exact command.
7. For format issues, include the result of running ValidateSamFile for BAMs or ValidateVariants for VCFs.
8. For weird results, include an illustrative example, e.g. attach IGV screenshots according to Article#5484.
9. For a seeming variant that is uncalled, include results of following Article#1235.

Did we ask for a bug report?


Then follow instructions in Article#1894.

Formatting tip!


Wrap blocks of code, error messages and BAM/VCF snippets--especially content with hashes (#)--with lines with three backticks ( ``` ) each to make a code block as demonstrated here.

Jump to another community
Picard 2.9.0 is now available. Download and read release notes here.
GATK 3.7 is here! Be sure to read the Version Highlights and optionally the full Release Notes.

GATK HaplotypeCaller isn't calling variants?

Hi guys,

I am working with three genomes from the same species. I have managed to call variants between the reference and two of the genomes but the third seems to be having an issue that I don't know. I processed them exactly in the same pipeline prior to calling the variants on them using HaplotypeCaller. However, on the third genome the algorithm produces an empty vcf file as if it encountered an exact replica of the reference genome. It doesn't seem like its encountering any type of error as the log file shows that it is walking through the genome fine and the standard error file is empty (no error messages)

My code for calling the variants is as follows:

java -Xmx6g -jar Documents/GenomeAnalysisTK-2.6-5-gba531bd/GenomeAnalysisTK.jar -T HaplotypeCaller -nct 4 -R equcab2.fa -I Documents/PhD_work/recal.bam -stand_call_conf 20 -stand_emit_conf 10.0 -o output.raw.snps.indels.vcf 1>> gatk_HaplotypeCaller.log 2>> gatk_HaplotypeCaller.stderr

I would really appreciate if someone can help me out with this.

Thank you! :-)

Best Answer

Answers

  • Thank you so much Geraldine....I realigned it and it worked...yaay!

Sign In or Register to comment.