The current GATK version is 3.7-0
Examples: Monday, today, last week, Mar 26, 3/26/04

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Get notifications!


You can opt in to receive email notifications, for example when your questions get answered or when there are new announcements, by following the instructions given here.

Did you remember to?


1. Search using the upper-right search box, e.g. using the error message.
2. Try the latest version of tools.
3. Include tool and Java versions.
4. Tell us whether you are following GATK Best Practices.
5. Include relevant details, e.g. platform, DNA- or RNA-Seq, WES (+capture kit) or WGS (PCR-free or PCR+), paired- or single-end, read length, expected average coverage, somatic data, etc.
6. For tool errors, include the error stacktrace as well as the exact command.
7. For format issues, include the result of running ValidateSamFile for BAMs or ValidateVariants for VCFs.
8. For weird results, include an illustrative example, e.g. attach IGV screenshots according to Article#5484.
9. For a seeming variant that is uncalled, include results of following Article#1235.

Did we ask for a bug report?


Then follow instructions in Article#1894.

Formatting tip!


Wrap blocks of code, error messages and BAM/VCF snippets--especially content with hashes (#)--with lines with three backticks ( ``` ) each to make a code block as demonstrated here.

Jump to another community
Picard 2.9.0 is now available. Download and read release notes here.
GATK 3.7 is here! Be sure to read the Version Highlights and optionally the full Release Notes.

switch off plot_tranches.R from GATK 1.6 VariantRecalibrator?

avilellaavilella Member Posts: 7
edited September 2013 in Ask the GATK team

Hi,

I am running the INDEL model of VariantRecalibrator with GATK 1.6 (last license-compatible version in our hands), and the very last step seems to crash when writing the plot using plot_Tranches.R (see below).

All the previous steps seem to run well on 9G RAM and I presume this plotting step just produces an image to manually inspect and nothing else. Is it possible to switch off the plotting step at all?

Thanks

java -Xmx8g -jar /my/path/GATK/GenomeAnalysisTK.jar -et NO_ET -T VariantRecalibrator -R /my/path/WholeGenomeFASTA/genome.fa -input /my/path/genome.vcf.tmp2 -resource:mills,known=true,training=true,truth=true,prior=12.0 /my/path/Annotation/Mills_Devine_2hit.indels.hg19.vcf -an QD -an FS -an ReadPosRankSum -an DP --mode INDEL -recalFile /my/path/test/file.INDEL.recal -tranchesFile /my/path/test/file.INDEL.tranches

[...]
INFO 10:46:37,310 VariantRecalibrator - Writing out recalibration table...
INFO 10:46:46,202 VariantRecalibrator - Executing: Rscript (resource)org/broadinstitute/sting/gatk/walkers/variantrecalibration/plot_Tranches.R /my/path/test/file.INDEL.tranches 2.15

PS: I tried adding the option "-rscriptFile /dev/null", but it also seems to crash at the same step:
INFO 11:25:10,870 VariantRecalibrator - Executing: Rscript /dev/null

Post edited by avilella on

Answers

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie Posts: 11,669 admin

    Hi @avilella,

    The plotting is indeed simply intended for visualization, it is not essential to the program run. Deactivating it from command line is not possible with the version you are using, but you could patch the code to deactivate the plotting function.

    Geraldine Van der Auwera, PhD

Sign In or Register to comment.