The current GATK version is 3.7-0
Examples: Monday, today, last week, Mar 26, 3/26/04

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Get notifications!


You can opt in to receive email notifications, for example when your questions get answered or when there are new announcements, by following the instructions given here.

Did you remember to?


1. Search using the upper-right search box, e.g. using the error message.
2. Try the latest version of tools.
3. Include tool and Java versions.
4. Tell us whether you are following GATK Best Practices.
5. Include relevant details, e.g. platform, DNA- or RNA-Seq, WES (+capture kit) or WGS (PCR-free or PCR+), paired- or single-end, read length, expected average coverage, somatic data, etc.
6. For tool errors, include the error stacktrace as well as the exact command.
7. For format issues, include the result of running ValidateSamFile for BAMs or ValidateVariants for VCFs.
8. For weird results, include an illustrative example, e.g. attach IGV screenshots according to Article#5484.
9. For a seeming variant that is uncalled, include results of following Article#1235.

Did we ask for a bug report?


Then follow instructions in Article#1894.

Formatting tip!


Wrap blocks of code, error messages and BAM/VCF snippets--especially content with hashes (#)--with lines with three backticks ( ``` ) each to make a code block as demonstrated here.

Jump to another community
Picard 2.9.0 is now available. Download and read release notes here.
GATK 3.7 is here! Be sure to read the Version Highlights and optionally the full Release Notes.

VariantRecalibrator parameter setting

Jiwoong_KIMJiwoong_KIM Member Posts: 3

I have HiSeq exome data, and using GATK v.2.5
While trying to do variant recalibration, I had got an error with default for -percentBad and --maxGaussians.
Searching the forum, according to the tip that suggested to loosen those, increasing the first to 0.05 or decreasing the second to 4,
the walker worked well. Actually either have been enough for one case of my data.
However, for an other data, it finally worked when both were adjusted.
Even, another case is being tested with more generous setting.
The options that I have controlled are below:
-minNumBad , -percentBad , --maxGaussians

What I wonder for options is,
1. Appropriate values could certainly differ sample by sample? ( Sometimes it's natural to try and adjust? )
2. Are there known values with the most generous level to keep reasonable performance? ( To what extent is it safe to loose the values? )

Any comment much appreciated. Let me know if I missed some information.
KIM

Comments

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie Posts: 11,651 admin

    Hi there,

    1. For samples that you compare with each other, you need to use the same values -- in fact you should call variants on them together then recalibrate the variants together. But if you're dealing with different cohorts of samples, then yes it's ok to adapt settings.

    2. Our Best Practices recommendations represent the optimal tradeoff, and each degree of loosening weakens the power of the model. Depending on your data the model will be more or less robust to this. You'll need to experiment to find the right settings for your data.

    Geraldine Van der Auwera, PhD

Sign In or Register to comment.