The current GATK version is 3.6-0
Examples: Monday, today, last week, Mar 26, 3/26/04

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Powered by Vanilla. Made with Bootstrap.
Register now for the upcoming GATK Best Practices workshop, Nov 7-8 at the Broad in Cambridge, MA. Open to all comers! More info and signup at

DepthofCoverage Walker

pmudvaripmudvari Washington DCPosts: 4Member
edited June 2013 in Ask the GATK team

Hi I am trying to run the DepthofCoverage walker from GATK for the first time and I am running into stumbling blocks. I am interested in getting coverage info for genes and I downloaded the Refseq genes list and am filtering and sorting according to specifications. I am using the script provided in the website. However, I am getting an error saying:

Can not open temporary file 1045: Too many open files at line 68, <$INPUT> line 1021.

I also checked the soft/hard limits for filesystem and it shows that my current system's limit is the following:

ulimit -u :386246  
ulimit -S -u: 386246  

I am stuck at this point and don't know how to proceed.

Any help is much appreciated.


Best Answer


  • Geraldine_VdAuweraGeraldine_VdAuwera Posts: 10,557Administrator, Dev admin

    Hi there,

    I'm not familiar with the -u flag of ulimit. Can you do ulimit -a | grep open instead? To be sure what you're getting is the limit on number of open files. Because that number you're showing there seems awfully large...

    Geraldine Van der Auwera, PhD

  • pmudvaripmudvari Washington DCPosts: 4Member

    Thanks for your prompt reply.
    I was just following instructions from a different post that I found.
    open files (-n) 1024
    Here's what I get when I ran your command:

  • pmudvaripmudvari Washington DCPosts: 4Member

    Oops here's what I got:

    open files (-n) 1024

  • pmudvaripmudvari Washington DCPosts: 4Member

    Thanks a lot. Will have to ask my sys admin to do it. Will let you know how it goes.

Sign In or Register to comment.