The current GATK version is 3.7-0
Examples: Monday, today, last week, Mar 26, 3/26/04

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Powered by Vanilla. Made with Bootstrap.
GATK 3.7 is here! Be sure to read the Version Highlights and optionally the full Release Notes.
Register now for the upcoming GATK Best Practices workshop, Feb 20-22 in Leuven, Belgium. Open to all comers! More info and signup at http://bit.ly/2i4mGxz

BaseRecalibrator error in a BAM validated with Picard

ocanelaocanela Member Posts: 5

Hello,

I have a BAM from RNA Seq experiment. The reads are aligned with tophat and then I filtered secondary reads, fixed mate pairs, marked duplicates with picard and realigned with gatk. However, when I try to use BaseRecalibrator function,

-T BaseRecalibrator -nct 12 -R ./SusGenome10v69/Sus_scrofa.Sscrofa10.2.69.dna.toplevel.fa -I ./7_15.corrected.ordered.sremoved.marked.fixed.realigned.fixed.corrected.ordered.sremoved.marked.fixed.realigned.fixed.bam -knownSites ./SusGenome10v69/Sus_scrofa.vcf -o ./7_15.RecalData.grp

It stops with the error:

ERROR ------------------------------------------------------------------------------------------
ERROR stack trace

org.broadinstitute.sting.utils.exceptions.ReviewedStingException: Trying to clip before the start or after the end of a read
at org.broadinstitute.sting.utils.clipping.ReadClipper.hardClipByReferenceCoordinates(ReadClipper.java:534)
at org.broadinstitute.sting.utils.clipping.ReadClipper.hardClipByReferenceCoordinatesLeftTail(ReadClipper.java:176)
at org.broadinstitute.sting.utils.clipping.ReadClipper.hardClipAdaptorSequence(ReadClipper.java:389)
at org.broadinstitute.sting.utils.clipping.ReadClipper.hardClipAdaptorSequence(ReadClipper.java:392)
at org.broadinstitute.sting.gatk.walkers.bqsr.BaseRecalibrator.map(BaseRecalibrator.java:244)
at org.broadinstitute.sting.gatk.walkers.bqsr.BaseRecalibrator.map(BaseRecalibrator.java:131)
at org.broadinstitute.sting.gatk.traversals.TraverseReadsNano$TraverseReadsMap.apply(TraverseReadsNano.java:230)
at org.broadinstitute.sting.gatk.traversals.TraverseReadsNano$TraverseReadsMap.apply(TraverseReadsNano.java:218)
at org.broadinstitute.sting.utils.nanoScheduler.NanoScheduler$ReadMapReduceJob.run(NanoScheduler.java:471)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
at java.util.concurrent.FutureTask.run(FutureTask.java:166)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:679)

ERROR ------------------------------------------------------------------------------------------
ERROR A GATK RUNTIME ERROR has occurred (version 2.4-7-g5e89f01):
ERROR
ERROR Please visit the wiki to see if this is a known problem
ERROR If not, please post the error, with stack trace, to the GATK forum
ERROR Visit our website and forum for extensive documentation and answers to
ERROR commonly asked questions http://www.broadinstitute.org/gatk
ERROR
ERROR MESSAGE: Trying to clip before the start or after the end of a read
ERROR ------------------------------------------------------------------------------------------

The bam file validates properly with the Picard's ValidateSamFile function. I tried with gatk versions, 2.3-9 and 2.4-7 obtaining the same results.

I used the same procedure with other samples without any problem. However, I am unable to recalibrate this sample. I tried to realign the reads with different tophat versions, applied different filters and different procedures, however i am unable to use the BaseRecalibrator function with this sample.

Could you help me?

Thanks!

Best Answer

Answers

Sign In or Register to comment.