What are the prerequisites for running GATK?

Geraldine_VdAuweraGeraldine_VdAuwera Administrator, Dev Posts: 10,299 admin
edited April 2015 in FAQs

1. Operating system

The GATK runs natively on most if not all flavors of UNIX, which includes MacOSX, Linux and BSD. It is possible to get it running on Windows using Cygwin, but we don't provide any support nor instructions for that.

2. Java 7 / 1.7

The GATK is a Java-based program, so you'll need to have Java installed on your machine. The Java version should be at 1.7 (at this time we don't officially support 1.8, and 1.6 no longer works). You can check what version you have by typing java -version at the command line. This article has some more details about what to do if you don't have the right version. Note that at this time we only support the Sun/Oracle Java JDK; OpenJDK is not supported.

4. R dependencies

Some of the GATK tools produce plots using R, so if you want to get the plots you'll need to have R and Rscript installed, as well as several R libraries. Full details can be found in the Tutorial on installing required software.

3. Familiarity with command-line programs

The GATK does not have a Graphical User Interface (GUI). You don't open it by clicking on the .jar file; you have to use the Console (or Terminal) to input commands. If this is all new to you, we recommend you first learn about that and follow some online tutorials before trying to use the GATK. It's not difficult but you'll need to learn some jargon and get used to living without a mouse. Trust us, it's a liberating experience :)

Post edited by Geraldine_VdAuwera on

Geraldine Van der Auwera, PhD

Comments

  • BlueBlue Member Posts: 48

    Without being intentionally pedantic, has the supported Java version now changed from 1.6 to 1.7 ? I'm assuming that earlier versions of GATK use 1.6 and at some point the later ones started using 1.7.

    Although I'm primarily using GATK from a university cluster, my IT guy has suggested that I also install Java 1.7 on my machine. Is this necessary as well ?

  • Geraldine_VdAuweraGeraldine_VdAuwera Administrator, Dev Posts: 10,299 admin

    Yes, we've switched to Java 7 in release 2.6. The announcement was delayed slightly but will go out by noon today (EST).

    You will need to install 1.7 on all machines that you intend to use to run GATK. Sorry for the inconvenience; this became a necessity, as wil be explained in the forthcoming Version Highlights document.

    Geraldine Van der Auwera, PhD

  • datakiddatakid At my deskMember Posts: 2

    Out of interest, is Java 8 supported yet?

  • SheilaSheila Broad InstituteMember, Broadie, Moderator, Dev Posts: 3,564 admin

    @datakid
    Hi,

    Not quite yet, but very soon! :)

    -Sheila

  • mglclinicalmglclinical USAMember Posts: 72

    Hi @Sheila

    We currently have OpenJDK 7 (1.7) on our server. I will ask my system administrator to install Sun/Oracle Java.

    In order to download and use Sun/Oracle Java on a server for commercial use, do we need to get any commercial license from Oracle ? , just like the way we got commercial license for GATK ? I am asking from a legal perspective.

    I am sorry if my question is naïve . I have downloaded Sun/Oracle Java on my personal laptops for personal use, but when using java for commercial GATK license, I want to make sure that there are no loose ends.

    Thanks,
    mglclinical

  • Geraldine_VdAuweraGeraldine_VdAuwera Administrator, Dev Posts: 10,299 admin

    I don't believe so but I'm not sure -- best check with Oracle themselves.

    Geraldine Van der Auwera, PhD

  • Geraldine_VdAuweraGeraldine_VdAuwera Administrator, Dev Posts: 10,299 admin

    Note that we're going to release GATK 3.6 very soon, which will run correctly on Java 8.

    Geraldine Van der Auwera, PhD

  • mglclinicalmglclinical USAMember Posts: 72

    Thank you @Geraldine_VdAuwera . I thought 4.0 is the successor after 3.5. Thank you for informing about 3.6

  • Geraldine_VdAuweraGeraldine_VdAuwera Administrator, Dev Posts: 10,299 admin

    GATK 4 will be the next generation once it's ready (it's a different codebase altogether) but in the meantime we're still making bug fixes etc in the GATK 3 codebase. It's possible that we'll have one more minor version (3.7) before 4.0 is ready for prime time. After that though I'll eat my hat if we're not ready to make 4.0 the official release ;)

    Geraldine Van der Auwera, PhD

  • mglclinicalmglclinical USAMember Posts: 72

    Thank you for the detailed update @Geraldine_VdAuwera :smile:

  • mglclinicalmglclinical USAMember Posts: 72

    Hi @Geraldine_VdAuwera ,

    I want to use most recent Picard_2.2.4 which requires java 1.8, but most recent GATK_3.5 requires java 1.7.

    Our system administrator advised me to have only one stable version java in our Linux server. Our linux server currently has java 1.7 , as GATK_3.5 requires it. So, I cannot use latest Picard.

    As GATK_3.6 release requires java 1.8, It will be easy for us to maintain just java 1.8 . Do you have any estimate on release date for GATK 3.6 ?

    Thanks,
    mglclinical

  • Geraldine_VdAuweraGeraldine_VdAuwera Administrator, Dev Posts: 10,299 admin

    Yes, the 3.6 release is almost ready. I expect we will release it next week. If you want to start trying it out, you can use the latest nightly build. It already supports Java 1.8 and is essentially the same as the upcoming release, just missing two or three last changes.

    Geraldine Van der Auwera, PhD

  • mglclinicalmglclinical USAMember Posts: 72

    Thank you

Sign In or Register to comment.