The current GATK version is 3.7-0
Examples: Monday, today, last week, Mar 26, 3/26/04

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Did you remember to?


1. Search using the upper-right search box, e.g. using the error message.
2. Try the latest version of tools.
3. Include tool and Java versions.
4. Tell us whether you are following GATK Best Practices.
5. Include relevant details, e.g. platform, DNA- or RNA-Seq, WES (+capture kit) or WGS (PCR-free or PCR+), paired- or single-end, read length, expected average coverage, somatic data, etc.
6. For tool errors, include the error stacktrace as well as the exact command.
7. For format issues, include the result of running ValidateSamFile for BAMs or ValidateVariants for VCFs.
8. For weird results, include an illustrative example, e.g. attach IGV screenshots according to Article#5484.
9. For a seeming variant that is uncalled, include results of following Article#1235.

Did we ask for a bug report?


Then follow instructions in Article#1894.

Formatting tip!


Surround blocks of code, error messages and BAM/VCF snippets--especially content with hashes (#)--with lines with three backticks ( ``` ) each to make a code block.
Powered by Vanilla. Made with Bootstrap.
Picard 2.9.0 is now available. Download and read release notes here.
GATK 3.7 is here! Be sure to read the Version Highlights and optionally the full Release Notes.

Base Recalibrator Error

AlexanderBAlexanderB Member Posts: 17
edited January 2013 in Ask the GATK team

Sorry to post such a simple question but I seem to be at my wits end. Base Recalibrator keeps giving me this error:

ERROR ------------------------------------------------------------------------------------------
ERROR A USER ERROR has occurred (version 2.0-36-gf5c1c1a):
ERROR
ERROR MESSAGE: The platform (HiSeq2000) associated with read group org.broadinstitute.sting.utils.sam.GATKSAMReadGroupRecord@32 is not a recognized platform. Implemented options are e.g. illumina, 454, and solid
ERROR ------------------------------------------------------------------------------------------

Why isn't HiSeq2000 recognized as Illumina?

Post edited by Geraldine_VdAuwera on

Best Answer

  • pdexheimerpdexheimer Member, Dev Posts: 544 ✭✭✭✭
    Accepted Answer

    This would be outside the scope of GATK. The simplest (though not quickest) way to change it would be to convert the file to SAM, manually edit the @RG tag and save it, then convert back to BAM. I would use samtools, though I think you could do the same thing with Picard.

    A more efficient method would be to use the "reheader" functionality that samtools and picard both offer, though that's a little bit more complicated.

Answers

  • pdexheimerpdexheimer Member, Dev Posts: 544 ✭✭✭✭

    Because GATK doesn't have NLP. it doesn't have a dictionary or anything of manufacturer -> model, and in fact doesn't even have a concept of manufacturer or model. They're just strings. Set it to Illumina and move on :)

  • AlexanderBAlexanderB Member Posts: 17

    Excellent! Thank you very much for the speedy reply. But what is the syntax option to do so?

  • pdexheimerpdexheimer Member, Dev Posts: 544 ✭✭✭✭
    Accepted Answer

    This would be outside the scope of GATK. The simplest (though not quickest) way to change it would be to convert the file to SAM, manually edit the @RG tag and save it, then convert back to BAM. I would use samtools, though I think you could do the same thing with Picard.

    A more efficient method would be to use the "reheader" functionality that samtools and picard both offer, though that's a little bit more complicated.

  • Geraldine_VdAuweraGeraldine_VdAuwera Cambridge, MAMember, Administrator, Broadie Posts: 11,405 admin

    To clarify further, it's not something you specify in your command-line; it should be written in the PL field in the BAM header (as indicated in the article on input files). See @pdexheimer's suggestions for how to do this.

    Geraldine Van der Auwera, PhD

Sign In or Register to comment.