Service Notice: Due to the blizzard currently hammering the US Northeast, the Broad is shut down and the GATK forum will be mostly unattended while we hunker down and sip hot cocoa with marshmallows. Assuming the power stays on and we're able to dig ourselves out of the snow when it's all over, normal service should resume Wednesday or Thursday.

BaseRecalibrator error in a BAM validated with Picard

ocanelaocanela Posts: 5Member


I have a BAM from RNA Seq experiment. The reads are aligned with tophat and then I filtered secondary reads, fixed mate pairs, marked duplicates with picard and realigned with gatk. However, when I try to use BaseRecalibrator function,

-T BaseRecalibrator -nct 12 -R ./SusGenome10v69/Sus_scrofa.Sscrofa10.2.69.dna.toplevel.fa -I ./7_15.corrected.ordered.sremoved.marked.fixed.realigned.fixed.corrected.ordered.sremoved.marked.fixed.realigned.fixed.bam -knownSites ./SusGenome10v69/Sus_scrofa.vcf -o ./7_15.RecalData.grp

It stops with the error:

ERROR ------------------------------------------------------------------------------------------
ERROR stack trace

org.broadinstitute.sting.utils.exceptions.ReviewedStingException: Trying to clip before the start or after the end of a read at org.broadinstitute.sting.utils.clipping.ReadClipper.hardClipByReferenceCoordinates( at org.broadinstitute.sting.utils.clipping.ReadClipper.hardClipByReferenceCoordinatesLeftTail( at org.broadinstitute.sting.utils.clipping.ReadClipper.hardClipAdaptorSequence( at org.broadinstitute.sting.utils.clipping.ReadClipper.hardClipAdaptorSequence( at at at org.broadinstitute.sting.gatk.traversals.TraverseReadsNano$TraverseReadsMap.apply( at org.broadinstitute.sting.gatk.traversals.TraverseReadsNano$TraverseReadsMap.apply( at org.broadinstitute.sting.utils.nanoScheduler.NanoScheduler$ at java.util.concurrent.Executors$ at java.util.concurrent.FutureTask$Sync.innerRun( at at java.util.concurrent.ThreadPoolExecutor.runWorker( at java.util.concurrent.ThreadPoolExecutor$ at

ERROR ------------------------------------------------------------------------------------------
ERROR A GATK RUNTIME ERROR has occurred (version 2.4-7-g5e89f01):
ERROR Please visit the wiki to see if this is a known problem
ERROR If not, please post the error, with stack trace, to the GATK forum
ERROR Visit our website and forum for extensive documentation and answers to
ERROR commonly asked questions
ERROR MESSAGE: Trying to clip before the start or after the end of a read
ERROR ------------------------------------------------------------------------------------------

The bam file validates properly with the Picard's ValidateSamFile function. I tried with gatk versions, 2.3-9 and 2.4-7 obtaining the same results.

I used the same procedure with other samples without any problem. However, I am unable to recalibrate this sample. I tried to realign the reads with different tophat versions, applied different filters and different procedures, however i am unable to use the BaseRecalibrator function with this sample.

Could you help me?


Best Answer


Sign In or Register to comment.