Bug Bulletin: The recent 3.2 release fixes many issues. If you run into a problem, please try the latest version before posting a bug report, as your problem may already have been solved.

NoClassDefFoundError error during build of 2.4+ from gatk-protected repository

mlindermmlinderm Posts: 19Member

Hi,

I am trying to build GATK w/ queue from HEAD of the gatk-protected repository (2a7af4316478348f7ea58e0803b3391593d6dbd6). I am getting the following error during the Queue extensions building phase:

[java] Exception in thread "main" java.lang.NoClassDefFoundError: org/broadinstitute/sting/commandline/MissingArgumentException
[java] at org.broadinstitute.sting.commandline.CommandLineProgram.start(CommandLineProgram.java:180)
[java] at org.broadinstitute.sting.commandline.CommandLineProgram.start(CommandLineProgram.java:152)
[java] at org.broadinstitute.sting.queue.extensions.gatk.GATKExtensionsGenerator.main(GATKExtensionsGenerator.java:104)
[java] Caused by: java.lang.ClassNotFoundException: org.broadinstitute.sting.commandline.MissingArgumentException
[java] at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
[java] at java.security.AccessController.doPrivileged(Native Method)
[java] at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
[java] at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
[java] at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
[java] at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
[java] ... 3 more

BUILD FAILED
/hpc/users/lindem03/packages/gatk-mssm/dev/build.xml:509: Java returned: 1
at org.apache.tools.ant.taskdefs.Java.execute(Java.java:111)
at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
at org.apache.tools.ant.Task.perform(Task.java:348)
at org.apache.tools.ant.Target.execute(Target.java:392)
at org.apache.tools.ant.Target.performTasks(Target.java:413)
at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1399)
at org.apache.tools.ant.Project.executeTarget(Project.java:1368)
at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
at org.apache.tools.ant.Project.executeTargets(Project.java:1251)
at org.apache.tools.ant.Main.runBuild(Main.java:811)
at org.apache.tools.ant.Main.startAnt(Main.java:217)
at org.apache.tools.ant.launch.Launcher.run(Launcher.java:280)
at org.apache.tools.ant.launch.Launcher.main(Launcher.java:109)

When I run ant in debug mode I see the directory with the newly build GATK classes on classpath. Is there something else I might be missing. I am trying to upgrade from 1.6...

Thanks,

Michael

Tagged:

Best Answer

Answers

Sign In or Register to comment.