Update snpEFF? Updating snpEff jar causes scalac to fail...

mlindermmlinderm Posts: 22Member

Hi GATK Team,

I have been experimenting with newer versions of snpEff and would like to incorporate a newer version into my local GATK build. However, when I update the jar to the snpeff 3.0 release (by updating the ivy specification and copying the jar in into the proper settings/repository/... directory) I get an internal scalar compiler error:

scala.compile.public:
[mkdir] Created dir: /hpc/users/lindem03/packages/gatk-mssm/dev/build/scala/classes
  [echo] Building Scala...
[scalac] Compiling 87 source files to /hpc/users/lindem03/packages/gatk-mssm/dev/build/scala/classes
[scalac] Compiling 107 source files to /hpc/users/lindem03/packages/gatk-mssm/dev/build/scala/classes
[scalac] Exception in thread "main" java.lang.AssertionError: assertion failed: List(object Byte, object Byte)
[scalac]     at scla.tools.nsc.symtab.Symbols$Symbol.suchThat(Symbols.scala:1056)
[scalac]     at scala.tools.nsc.symtab.Symbols$Symbol.companionModule0(Symbols.scala:1271)
[scalac]     at scala.tools.nsc.symtab.Symbols$Symbol.companionModule(Symbols.scala:1281)
[scalac]     at scala.tools.nsc.symtab.Symbols$Symbol.linkedClassOfClass(Symbols.scala:1302)
[scalac]     at scala.tools.nsc.symtab.Definitions$definitions$.addModuleMethod$1(Definitions.scala:711)
[scalac]     at scala.tools.nsc.symtab.Definitions$definitions$.initValueClasses(Definitions.scala:714)
[scalac]     at scala.tools.nsc.symtab.Definitions$definitions$.init(Definitions.scala:791)
[scalac]     at scala.tools.nsc.Global$Run.<init>(Global.scala:604)
[scalac]     at scala.tools.nsc.Main$.process(Main.scala:105)
[scalac]     at scala.tools.nsc.Main$.main(Main.scala:120)
[scalac]     at scala.tools.nsc.Main.main(Main.scala)

Any thoughts? Do I need to modify the snpEff jar in some way to get it play nicely with GATK? That error is so opaque I am not sure where to start debugging. This is against a "clean" directory (I ran ant clean) with java 1.6.0_30

$ java -version
java version "1.6.0_30"
Java(TM) SE Runtime Environment (build 1.6.0_30-b12)
Java HotSpot(TM) 64-Bit Server VM (build 20.5-b03, mixed mode)

and GATK 1.6-24-gdc14575.

Tagged:

Answers

  • droazendroazen Posts: 51GATK Developer mod

    The GATK currently only works with snpEff 2.0.5. It's possible that we'll upgrade our support for snpEff at some point in the future, but there are no plans to do so at this time.

    If you want to run newer versions of snpEff, you'll need to run snpEff standalone, as the GATK's VariantAnnotator is not able to parse the output from versions other than 2.0.5.

    David

  • mlindermmlinderm Posts: 22Member

    Thanks. But that is not really what I am asking about. I have the done the above quite successfully in a jar that wraps around GATK. However, I am interested in using some of the snpEff internals in a GATK walker was hoping to replace the snpEff jar in a local fork of GATK but when I update the jar as described in my original question I get an error in scalac. Do you have any thoughts on what is causing the scalac build error?

  • droazendroazen Posts: 51GATK Developer mod

    Unfortunately this is not something that we really have time to support -- you'll have to work through this problem on your own. I can give you a quick suggestion, though: trying compiling the GATK alone without Queue by typing "ant gatk". This will avoid invoking scalac at all during the build.

    David

Sign In or Register to comment.