Bug Bulletin: we have identified a bug that affects indexing when producing gzipped VCFs. This will be fixed in the upcoming 3.2 release; in the meantime you need to reindex gzipped VCFs using Tabix.

What are the prerequisites for running GATK?

Geraldine_VdAuweraGeraldine_VdAuwera Posts: 5,235Administrator, GSA Member admin
edited October 2013 in FAQs

1. Operating system

The GATK runs natively on most if not all flavors of UNIX, which includes MacOSX, Linux and BSD. It is possible to get it running on Windows using Cygwin, but we don't provide any support nor instructions for that.

2. Java

The GATK is a Java-based program, so you'll need to have Java installed on your machine. The Java version should be at 1.6 (at this time we don't support 1.7). You can check what version you have by typing java -version at the command line. This article has some more details about what to do if you don't have the right version. Note that at this time we only support the Sun/Oracle Java JDK; OpenJDK is not supported.

3. Familiarity with command-line programs

The GATK does not have a Graphical User Interface (GUI). You don't open it by clicking on the .jar file; you have to use the Console (or Terminal) to input commands. If this is all new to you, we recommend you first learn about that and follow some online tutorials before trying to use the GATK. It's not difficult but you'll need to learn some jargon and get used to living without a mouse...

4. Other

Some of the GATK tools produce plots using R, so if you want to get the plots you'll need to have R installed, as well as several R libraries. Full details can be found in the Tutorial on prerequisites.

Post edited by Geraldine_VdAuwera on

Geraldine Van der Auwera, PhD

Tagged:

Comments

  • BlueBlue Posts: 17Member

    Without being intentionally pedantic, has the supported Java version now changed from 1.6 to 1.7 ? I'm assuming that earlier versions of GATK use 1.6 and at some point the later ones started using 1.7.

    Although I'm primarily using GATK from a university cluster, my IT guy has suggested that I also install Java 1.7 on my machine. Is this necessary as well ?

  • Geraldine_VdAuweraGeraldine_VdAuwera Posts: 5,235Administrator, GSA Member admin

    Yes, we've switched to Java 7 in release 2.6. The announcement was delayed slightly but will go out by noon today (EST).

    You will need to install 1.7 on all machines that you intend to use to run GATK. Sorry for the inconvenience; this became a necessity, as wil be explained in the forthcoming Version Highlights document.

    Geraldine Van der Auwera, PhD

Sign In or Register to comment.