Service Notice: Due to the blizzard currently hammering the US Northeast, the Broad is shut down and the GATK forum will be mostly unattended while we hunker down and sip hot cocoa with marshmallows. Assuming the power stays on and we're able to dig ourselves out of the snow when it's all over, normal service should resume Wednesday or Thursday.


SystemSystem Posts: 226Administrator admin
edited July 2012 in Tool Bulletin

A new tool has been released!

Check out the documentation at VariantsToBinaryPed.


  • M_TriebM_Trieb Posts: 5Member

    I have had trouble getting the VariantsToBinaryPed tool to work. Below is the error I have been getting. I am using a .vcf file produced by the UnifiedGenotyper and selected down to those variants present in one of the 11 people in the test file I am using (used SelectVariants to subset). I used VariantValidator to check the test file and there were no errors.

    WARN 14:41:13,090 VCFStandardHeaderLines$Standards - Repairing standard header line for field AF because -- count types disagree; header has UNBOUNDED but standard is A INFO 14:41:13,808 GATKRunReport - Uploaded run statistics report to AWS S3

    ERROR ------------------------------------------------------------------------------------------
    ERROR stack trace

    java.lang.ArrayIndexOutOfBoundsException: 1 at org.broadinstitute.sting.gatk.walkers.variantutils.VariantsToBinaryPed.initialize( at org.broadinstitute.sting.gatk.executive.LinearMicroScheduler.execute( at org.broadinstitute.sting.gatk.GenomeAnalysisEngine.execute( at org.broadinstitute.sting.gatk.CommandLineExecutable.execute( at org.broadinstitute.sting.commandline.CommandLineProgram.start( at org.broadinstitute.sting.commandline.CommandLineProgram.start( at org.broadinstitute.sting.gatk.CommandLineGATK.main(

    ERROR ------------------------------------------------------------------------------------------
    ERROR A GATK RUNTIME ERROR has occurred (version 2.0-36-gf5c1c1a):
    ERROR Please visit the wiki to see if this is a known problem
    ERROR If not, please post the error, with stack trace, to the GATK forum
    ERROR Visit our website and forum for extensive documentation and answers to
    ERROR commonly asked questions
    ERROR ------------------------------------------------------------------------------------------

    Also, can you post an example metaData file? I have tried reformating my .fam file a number of ways to see if that is a problem and haven't been to overcome this array out of bounds error.

    Thank you

  • hmk123hmk123 Posts: 11Member

    Any chance you can put an example of the metaData file up on the web? I am getting the same error message that another person commented about that there is no metaData for my subjects. I tried to run the VariantsToBinaryPed on a single subject, but I'm still having problems. I thought it could be my input metaData file, but I'm not sure if I have that wrong. Thanks!

  • monsunmonsun Posts: 6Member

    Has anyone had any success with this tool? Please show how you run it and how the .fam file should look!

    Thank you

  • Geraldine_VdAuweraGeraldine_VdAuwera Posts: 6,957Administrator, GATK Developer admin

    We have expanded the technical documentation on this tool; it will be available later today when we release version 2.2.

    Geraldine Van der Auwera, PhD

Sign In or Register to comment.